aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/datrie/datrie-0.8.2-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/datrie/datrie-0.8.2-r1.ebuild b/dev-python/datrie/datrie-0.8.2-r1.ebuild
index 3bbd197d7..94fcd2777 100644
--- a/dev-python/datrie/datrie-0.8.2-r1.ebuild
+++ b/dev-python/datrie/datrie-0.8.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,5 +28,7 @@ distutils_enable_tests pytest
python_prepare_all() {
# do not depend on pytest-runner
sed -i "/pytest-runner/d" setup.py || die
+ # https://github.com/pytries/datrie/pull/99
+ sed -i "12s/struct AlphaMap:/ctypedef struct AlphaMap:/" src/cdatrie.pxd || die
distutils-r1_python_prepare_all
}