aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-09-16 08:09:38 -0700
committerMatt Turner <mattst88@gentoo.org>2018-09-16 08:09:38 -0700
commit3ee52a24b5e307584f726ebcd9da7b4ff936ad90 (patch)
tree28e93425d1e8bdb5dfe6255dc7957978c5b46f6b
parentcatalyst-auto: Build only 64-bit userland on ppc64 and remove '64ul' (diff)
downloadreleng-3ee52a24b5e307584f726ebcd9da7b4ff936ad90.tar.gz
releng-3ee52a24b5e307584f726ebcd9da7b4ff936ad90.tar.bz2
releng-3ee52a24b5e307584f726ebcd9da7b4ff936ad90.zip
catalyst-auto: Use xz instead of bz2 for powerpc builds
-rw-r--r--tools/catalyst-auto-ppc.conf10
-rw-r--r--tools/catalyst-auto-ppc64.conf10
2 files changed, 10 insertions, 10 deletions
diff --git a/tools/catalyst-auto-ppc.conf b/tools/catalyst-auto-ppc.conf
index 71a4e840..c5d09d09 100644
--- a/tools/catalyst-auto-ppc.conf
+++ b/tools/catalyst-auto-ppc.conf
@@ -26,9 +26,9 @@ give_latest_from_dates() {
# Replace the date/time stamp in the filename to "latest".
# Forms we handle:
-# stage3-xxx-2018.0.tar.bz2
-# stage3-xxx-20180116.tar.bz2
-# stage3-xxx-20180116T015819Z.tar.bz2
+# stage3-xxx-2018.0.tar.xz
+# stage3-xxx-20180116.tar.xz
+# stage3-xxx-20180116T015819Z.tar.xz
convert_filename() {
sed -E 's:-20[0-9]+(\.[0-9]+|T[0-9]+Z)?:-latest:g'
}
@@ -38,7 +38,7 @@ update_symlinks() {
local d f
for d in "${BUILD_SRCDIR_BASE}/builds/default/ppc" ; do
pushd "${d}" >/dev/null
- for f in $(ls stage3-ppc-*bz2 | grep -v latest | give_latest_from_dates) ; do
+ for f in $(ls stage3-ppc-*xz | grep -v latest | give_latest_from_dates) ; do
local of=$(echo "${f}" | convert_filename)
ln -sf "${f}" "${of}"
done
@@ -57,7 +57,7 @@ post_build() {
case ${spec} in
stage3.spec)
- upload stage3-ppc-*${TIMESTAMP}*.bz2*
+ upload stage3-ppc-*${TIMESTAMP}*.xz*
;;
esac
diff --git a/tools/catalyst-auto-ppc64.conf b/tools/catalyst-auto-ppc64.conf
index bb4d50d0..ce5aa5c8 100644
--- a/tools/catalyst-auto-ppc64.conf
+++ b/tools/catalyst-auto-ppc64.conf
@@ -27,9 +27,9 @@ give_latest_from_dates() {
# Replace the date/time stamp in the filename to "latest".
# Forms we handle:
-# stage3-xxx-2018.0.tar.bz2
-# stage3-xxx-20180116.tar.bz2
-# stage3-xxx-20180116T015819Z.tar.bz2
+# stage3-xxx-2018.0.tar.xz
+# stage3-xxx-20180116.tar.xz
+# stage3-xxx-20180116T015819Z.tar.xz
convert_filename() {
sed -E 's:-20[0-9]+(\.[0-9]+|T[0-9]+Z)?:-latest:g'
}
@@ -40,7 +40,7 @@ update_symlinks() {
for d in "${BUILD_SRCDIR_BASE}/builds/default/ppc64" ; do
pushd "${d}" >/dev/null
for t in ppc64; do
- for f in $(ls stage3-${t}-*bz2 | grep -v latest | give_latest_from_dates) ; do
+ for f in $(ls stage3-${t}-*xz | grep -v latest | give_latest_from_dates) ; do
local of=$(echo "${f}" | convert_filename)
ln -sf "${f}" "${of}"
done
@@ -63,7 +63,7 @@ post_build() {
upload *${TIMESTAMP}*.iso*
;;
stage3*.spec)
- upload stage3-ppc64-*${TIMESTAMP}*.bz2*
+ upload stage3-ppc64-*${TIMESTAMP}*.xz*
;;
esac