diff options
author | Juan Quintela <quintela@redhat.com> | 2009-06-25 00:08:03 +0200 |
---|---|---|
committer | Anthony Liguori <aliguori@us.ibm.com> | 2009-06-29 14:18:06 -0500 |
commit | eda959bda7db6a9db7fe63c9a932526296e4271a (patch) | |
tree | f1f8344980a7fea95d3a03b1d12c038628026cfa /Makefile | |
parent | Rename BLOCK_OBJS to block-obj-y (diff) | |
download | qemu-kvm-eda959bda7db6a9db7fe63c9a932526296e4271a.tar.gz qemu-kvm-eda959bda7db6a9db7fe63c9a932526296e4271a.tar.bz2 qemu-kvm-eda959bda7db6a9db7fe63c9a932526296e4271a.zip |
Rename AUDIO_OBJS to audio-obj-y
Signed-off-by: Juan Quintela <quintela@redhat.com>
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 24 |
1 files changed, 12 insertions, 12 deletions
@@ -123,45 +123,45 @@ else OBJS+=migration-exec.o endif -AUDIO_OBJS = audio.o noaudio.o wavaudio.o mixeng.o +audio-obj-y = audio.o noaudio.o wavaudio.o mixeng.o ifdef CONFIG_SDL -AUDIO_OBJS += sdlaudio.o +audio-obj-y += sdlaudio.o endif ifdef CONFIG_OSS -AUDIO_OBJS += ossaudio.o +audio-obj-y += ossaudio.o endif ifdef CONFIG_COREAUDIO -AUDIO_OBJS += coreaudio.o +audio-obj-y += coreaudio.o AUDIO_PT = yes endif ifdef CONFIG_ALSA -AUDIO_OBJS += alsaaudio.o +audio-obj-y += alsaaudio.o endif ifdef CONFIG_DSOUND -AUDIO_OBJS += dsoundaudio.o +audio-obj-y += dsoundaudio.o endif ifdef CONFIG_FMOD -AUDIO_OBJS += fmodaudio.o +audio-obj-y += fmodaudio.o audio/audio.o audio/fmodaudio.o: CPPFLAGS := -I$(CONFIG_FMOD_INC) $(CPPFLAGS) endif ifdef CONFIG_ESD AUDIO_PT = yes AUDIO_PT_INT = yes -AUDIO_OBJS += esdaudio.o +audio-obj-y += esdaudio.o endif ifdef CONFIG_PA AUDIO_PT = yes AUDIO_PT_INT = yes -AUDIO_OBJS += paaudio.o +audio-obj-y += paaudio.o endif ifdef AUDIO_PT LDFLAGS += -pthread endif ifdef AUDIO_PT_INT -AUDIO_OBJS += audio_pt_int.o +audio-obj-y += audio_pt_int.o endif -AUDIO_OBJS+= wavcapture.o -OBJS+=$(addprefix audio/, $(AUDIO_OBJS)) +audio-obj-y += wavcapture.o +OBJS+=$(addprefix audio/, $(audio-obj-y)) OBJS+=keymaps.o ifdef CONFIG_SDL |