diff options
author | Alexander Graf <agraf@suse.de> | 2009-05-11 17:41:42 +0200 |
---|---|---|
committer | Anthony Liguori <aliguori@us.ibm.com> | 2009-05-22 10:50:35 -0500 |
commit | 769ce76d0e220e1ecde16154e76d43cf7099e7c6 (patch) | |
tree | a81618ec07abe2f0cfea6aa0d34de86b81364487 /Makefile | |
parent | USB serial device support (diff) | |
download | qemu-kvm-769ce76d0e220e1ecde16154e76d43cf7099e7c6.tar.gz qemu-kvm-769ce76d0e220e1ecde16154e76d43cf7099e7c6.tar.bz2 qemu-kvm-769ce76d0e220e1ecde16154e76d43cf7099e7c6.zip |
Add HTTP protocol using curl v6
Currently Qemu can read from posix I/O and NBD. This patch adds a
third protocol to the game: HTTP.
In certain situations it can be useful to access HTTP data directly,
for example if you want to try out an http provided OS image, but
don't know if you want to download it yet.
Using this patch you can now try it on on the fly. Just use it like:
qemu -cdrom http://host/path/my.iso
Signed-off-by: Alexander Graf <agraf@suse.de>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -80,6 +80,10 @@ endif BLOCK_OBJS += block/raw-posix.o endif +ifdef CONFIG_CURL +BLOCK_OBJS += block/curl.o +endif + ###################################################################### # libqemu_common.a: Target independent part of system emulation. The # long term path is to suppress *all* target specific code in case of @@ -196,6 +200,8 @@ ifdef CONFIG_XEN OBJS += $(XEN_OBJS) endif +LIBS+=$(CURL_LIBS) + cocoa.o: cocoa.m keymaps.o: keymaps.c keymaps.h |