aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Tosatti <mtosatti@redhat.com>2009-10-14 18:17:41 -0300
committerMarcelo Tosatti <mtosatti@redhat.com>2009-10-14 18:17:41 -0300
commit784d3f4620cd084bfb5ef879fc127f19f9e691e9 (patch)
treed866be004aa5b28e2c615c4878b03d8a3818cbee /Makefile.target
parentMerge commit '3d0f151783dcb56284d56502c3ffe5430e540e38' into upstream-merge (diff)
parentOnly compile isa_mmio when one target uses it (diff)
downloadqemu-kvm-784d3f4620cd084bfb5ef879fc127f19f9e691e9.tar.gz
qemu-kvm-784d3f4620cd084bfb5ef879fc127f19f9e691e9.tar.bz2
qemu-kvm-784d3f4620cd084bfb5ef879fc127f19f9e691e9.zip
Merge commit '185c66c81d95a929bc3d38ca52887a8da1e6887f' into upstream-merge
* commit '185c66c81d95a929bc3d38ca52887a8da1e6887f': Only compile isa_mmio when one target uses it Only compile usb_ohci when one target uses it Conflicts: Makefile.target Signed-off-by: Marcelo Tosatti <mtosatti@redhat.com>
Diffstat (limited to 'Makefile.target')
-rw-r--r--Makefile.target6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.target b/Makefile.target
index f76c1f6d2..a083b2ee0 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -166,8 +166,7 @@ endif #CONFIG_BSD_USER
# System emulator target
ifdef CONFIG_SOFTMMU
-obj-y = vl.o monitor.o pci.o isa_mmio.o machine.o \
- gdbstub.o
+obj-y = vl.o monitor.o pci.o machine.o gdbstub.o
# virtio has to be here due to weird dependency between PCI and virtio-net.
# need to fix this properly
obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-pci.o
@@ -176,6 +175,7 @@ obj-$(CONFIG_KVM) += kvm.o kvm-all.o
# so moved it from Makefile.hw to Makefile.target for now
obj-y += msix.o
+obj-$(CONFIG_ISA_MMIO) += isa_mmio.o
LIBS+=-lz
sound-obj-y =
@@ -195,7 +195,7 @@ QEMU_CFLAGS += $(VNC_SASL_CFLAGS)
obj-$(CONFIG_XEN) += xen_machine_pv.o xen_domainbuild.o
# USB layer
-obj-y += usb-ohci.o
+obj-$(CONFIG_USB_OHCI) += usb-ohci.o
# PCI network cards
obj-y += eepro100.o