aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-03-20 12:43:25 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2011-03-20 12:43:25 -0400
commit134bd74b3c6b2068d13693dbd35be0daaaf8be27 (patch)
treef35072fbaaa210345dc36e4f40340aace6071141
parentInitial commit. README describes repository layout. (diff)
downloadpatches-134bd74b3c6b2068d13693dbd35be0daaaf8be27.tar.gz
patches-134bd74b3c6b2068d13693dbd35be0daaaf8be27.tar.bz2
patches-134bd74b3c6b2068d13693dbd35be0daaaf8be27.zip
Initial commit of 9.0 branch patches.
-rw-r--r--postgresql-9.0-autoconf.patch14
-rw-r--r--postgresql-9.0-base.patch147
-rw-r--r--postgresql-9.0-regress.patch55
-rw-r--r--postgresql-9.0-server.patch195
4 files changed, 411 insertions, 0 deletions
diff --git a/postgresql-9.0-autoconf.patch b/postgresql-9.0-autoconf.patch
new file mode 100644
index 0000000..8ed148e
--- /dev/null
+++ b/postgresql-9.0-autoconf.patch
@@ -0,0 +1,14 @@
+diff -Naur a/configure.in b/configure.in
+--- a/configure.in 2010-07-08 22:43:12.000000000 -0400
++++ b/configure.in 2010-07-12 00:13:37.585527031 -0400
+@@ -19,10 +19,6 @@
+
+ AC_INIT([PostgreSQL], [9.0.3], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.63], [], [m4_fatal([Autoconf version 2.63 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2010, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
diff --git a/postgresql-9.0-base.patch b/postgresql-9.0-base.patch
new file mode 100644
index 0000000..a4d7b50
--- /dev/null
+++ b/postgresql-9.0-base.patch
@@ -0,0 +1,147 @@
+diff -Naur postgresql-9.0.3.orig/contrib/Makefile postgresql-9.0.3/contrib/Makefile
+--- postgresql-9.0.3.orig/contrib/Makefile 2011-02-02 07:37:16.654175660 -0500
++++ postgresql-9.0.3/contrib/Makefile 2011-02-08 05:54:00.145582001 -0500
+@@ -5,51 +5,10 @@
+ include $(top_builddir)/src/Makefile.global
+
+ SUBDIRS = \
+- adminpack \
+- auto_explain \
+- btree_gin \
+- btree_gist \
+- chkpass \
+- citext \
+- cube \
+- dblink \
+- dict_int \
+- dict_xsyn \
+- earthdistance \
+- fuzzystrmatch \
+- hstore \
+- intagg \
+- intarray \
+- isn \
+- lo \
+- ltree \
+ oid2name \
+- pageinspect \
+- passwordcheck \
+- pg_archivecleanup \
+- pg_buffercache \
+- pg_freespacemap \
+- pg_standby \
+- pg_stat_statements \
+- pg_trgm \
+- pg_upgrade \
+- pg_upgrade_support \
+ pgbench \
+- pgcrypto \
+- pgrowlocks \
+- pgstattuple \
+- seg \
+- spi \
+- tablefunc \
+- test_parser \
+- tsearch2 \
+- unaccent \
+ vacuumlo
+
+-ifeq ($(with_openssl),yes)
+-SUBDIRS += sslinfo
+-endif
+-
+ ifeq ($(with_ossp_uuid),yes)
+ SUBDIRS += uuid-ossp
+ endif
+diff -Naur postgresql-9.0.3.orig/src/backend/Makefile postgresql-9.0.3/src/backend/Makefile
+--- postgresql-9.0.3.orig/src/backend/Makefile 2011-02-02 07:37:56.403870592 -0500
++++ postgresql-9.0.3/src/backend/Makefile 2011-02-08 05:57:26.078497002 -0500
+@@ -45,7 +45,7 @@
+
+ ##########################################################################
+
+-all: submake-libpgport submake-schemapg postgres $(POSTGRES_IMP)
++all: someheaders
+
+ ifneq ($(PORTNAME), cygwin)
+ ifneq ($(PORTNAME), win32)
+@@ -114,7 +114,7 @@
+ endif # aix
+
+ # Update the commonly used headers before building the subdirectories
+-$(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/catalog/schemapg.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
++someheaders $(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/catalog/schemapg.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
+
+ # run this unconditionally to avoid needing to know its dependencies here:
+ submake-schemapg:
+@@ -191,23 +191,7 @@
+
+ ##########################################################################
+
+-install: all installdirs install-bin
+-ifeq ($(PORTNAME), cygwin)
+-ifeq ($(MAKE_DLL), true)
+- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+-endif
+-endif
+-ifeq ($(PORTNAME), win32)
+-ifeq ($(MAKE_DLL), true)
+- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+-endif
+-endif
+- $(MAKE) -C catalog install-data
+- $(MAKE) -C tsearch install-data
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample '$(DESTDIR)$(datadir)/pg_hba.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample '$(DESTDIR)$(datadir)/pg_ident.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/access/transam/recovery.conf.sample '$(DESTDIR)$(datadir)/recovery.conf.sample'
++install:
+
+ install-bin: postgres $(POSTGRES_IMP) installdirs
+ $(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
+diff -Naur postgresql-9.0.3.orig/src/bin/Makefile postgresql-9.0.3/src/bin/Makefile
+--- postgresql-9.0.3.orig/src/bin/Makefile 2011-02-02 07:38:35.133570047 -0500
++++ postgresql-9.0.3/src/bin/Makefile 2011-02-08 05:58:48.819847001 -0500
+@@ -13,8 +13,7 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-SUBDIRS = initdb pg_ctl pg_dump \
+- psql scripts pg_config pg_controldata pg_resetxlog
++SUBDIRS = pg_dump psql scripts pg_config
+ ifeq ($(PORTNAME), win32)
+ SUBDIRS+=pgevent
+ endif
+diff -Naur postgresql-9.0.3.orig/src/include/pg_config_manual.h postgresql-9.0.3/src/include/pg_config_manual.h
+--- postgresql-9.0.3.orig/src/include/pg_config_manual.h 2011-02-02 07:38:45.143493902 -0500
++++ postgresql-9.0.3/src/include/pg_config_manual.h 2011-02-08 05:59:32.021437001 -0500
+@@ -141,7 +141,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "@GENTOO_PORTAGE_EPREFIX@/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+diff -Naur postgresql-9.0.3.orig/src/Makefile postgresql-9.0.3/src/Makefile
+--- postgresql-9.0.3.orig/src/Makefile 2011-02-02 07:37:56.283870942 -0500
++++ postgresql-9.0.3/src/Makefile 2011-02-08 06:00:51.591202002 -0500
+@@ -15,17 +15,11 @@
+
+ all install installdirs uninstall distprep:
+ $(MAKE) -C port $@
+- $(MAKE) -C timezone $@
+ $(MAKE) -C backend $@
+- $(MAKE) -C backend/utils/mb/conversion_procs $@
+- $(MAKE) -C backend/snowball $@
+ $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+- $(MAKE) -C backend/replication/libpqwalreceiver $@
+ $(MAKE) -C bin $@
+- $(MAKE) -C pl $@
+ $(MAKE) -C makefiles $@
+- $(MAKE) -C test/regress $@
+
+ install: install-local
+
diff --git a/postgresql-9.0-regress.patch b/postgresql-9.0-regress.patch
new file mode 100644
index 0000000..c68b663
--- /dev/null
+++ b/postgresql-9.0-regress.patch
@@ -0,0 +1,55 @@
+diff -Naur postgresql-8.4.7.orig/src/test/regress/pg_regress.c postgresql-8.4.7/src/test/regress/pg_regress.c
+--- postgresql-8.4.7.orig/src/test/regress/pg_regress.c 2011-02-02 07:36:51.264416667 -0500
++++ postgresql-8.4.7/src/test/regress/pg_regress.c 2011-02-06 15:32:38.662748002 -0500
+@@ -790,8 +790,8 @@
+ sprintf(tmp, "%s/install/%s", temp_install, datadir);
+ datadir = tmp;
+
+- /* psql will be installed into temp-install bindir */
+- psqldir = bindir;
++ /* psql will be installed into temp-install bindir
++ psqldir = bindir; */
+
+ /*
+ * Set up shared library paths to include the temp install.
+@@ -889,7 +889,7 @@
+
+ /* And now we can build and execute the shell command */
+ snprintf(psql_cmd, sizeof(psql_cmd),
+- SYSTEMQUOTE "\"%s%spsql\" -X -c \"%s\" \"%s\"" SYSTEMQUOTE,
++ SYSTEMQUOTE "\"%s%spsql\" -h @SOCKETDIR@ -X -c \"%s\" \"%s\"" SYSTEMQUOTE,
+ psqldir ? psqldir : "",
+ psqldir ? "/" : "",
+ query_escaped,
+@@ -2137,8 +2137,8 @@
+ * Check if there is a postmaster running already.
+ */
+ snprintf(buf2, sizeof(buf2),
+- SYSTEMQUOTE "\"%s/psql\" -X postgres <%s 2>%s" SYSTEMQUOTE,
+- bindir, DEVNULL, DEVNULL);
++ SYSTEMQUOTE "\"%s/psql\" -h @SOCKETDIR@ -X postgres <%s 2>%s" SYSTEMQUOTE,
++ psqldir, DEVNULL, DEVNULL);
+
+ for (i = 0; i < 16; i++)
+ {
+@@ -2169,7 +2169,7 @@
+ */
+ header(_("starting postmaster"));
+ snprintf(buf, sizeof(buf),
+- SYSTEMQUOTE "\"%s/postgres\" -D \"%s/data\" -F%s -c \"listen_addresses=%s\" > \"%s/log/postmaster.log\" 2>&1" SYSTEMQUOTE,
++ SYSTEMQUOTE "\"%s/postgres\" -k @SOCKETDIR@ -D \"%s/data\" -F%s -c \"listen_addresses=%s\" > \"%s/log/postmaster.log\" 2>&1" SYSTEMQUOTE,
+ bindir, temp_install,
+ debug ? " -d 5" : "",
+ hostname ? hostname : "",
+diff -Naur postgresql-8.4.7.orig/src/test/regress/pg_regress_main.c postgresql-8.4.7/src/test/regress/pg_regress_main.c
+--- postgresql-8.4.7.orig/src/test/regress/pg_regress_main.c 2011-02-02 07:36:51.344375302 -0500
++++ postgresql-8.4.7/src/test/regress/pg_regress_main.c 2011-02-06 15:33:06.318913001 -0500
+@@ -59,7 +59,7 @@
+ add_stringlist_item(expectfiles, expectfile);
+
+ snprintf(psql_cmd, sizeof(psql_cmd),
+- SYSTEMQUOTE "\"%s%spsql\" -X -a -q -d \"%s\" < \"%s\" > \"%s\" 2>&1" SYSTEMQUOTE,
++ SYSTEMQUOTE "\"%s%spsql\" -h @SOCKETDIR@ -X -a -q -d \"%s\" < \"%s\" > \"%s\" 2>&1" SYSTEMQUOTE,
+ psqldir ? psqldir : "",
+ psqldir ? "/" : "",
+ dblist->str,
diff --git a/postgresql-9.0-server.patch b/postgresql-9.0-server.patch
new file mode 100644
index 0000000..e746239
--- /dev/null
+++ b/postgresql-9.0-server.patch
@@ -0,0 +1,195 @@
+diff -Naur postgresql-9.0.3.orig/contrib/adminpack/Makefile postgresql-9.0.3/contrib/adminpack/Makefile
+--- postgresql-9.0.3.orig/contrib/adminpack/Makefile 2011-02-02 07:37:16.724174266 -0500
++++ postgresql-9.0.3/contrib/adminpack/Makefile 2011-02-06 18:46:37.086945001 -0500
+@@ -1,7 +1,7 @@
+ # $PostgreSQL: pgsql/contrib/adminpack/Makefile,v 1.6 2007/11/10 23:59:50 momjian Exp $
+
+ MODULE_big = adminpack
+-PG_CPPFLAGS = -I$(libpq_srcdir)
++PG_CPPFLAGS = -I$(libpq_srcdir) -I../../src/include/
+ DATA_built = adminpack.sql
+ DATA = uninstall_adminpack.sql
+ OBJS = adminpack.o
+diff -Naur postgresql-9.0.3.orig/contrib/dblink/Makefile postgresql-9.0.3/contrib/dblink/Makefile
+--- postgresql-9.0.3.orig/contrib/dblink/Makefile 2011-02-02 07:37:19.904150270 -0500
++++ postgresql-9.0.3/contrib/dblink/Makefile 2011-02-06 18:47:10.086945001 -0500
+@@ -1,7 +1,7 @@
+ # $PostgreSQL: pgsql/contrib/dblink/Makefile,v 1.15 2007/11/10 23:59:50 momjian Exp $
+
+ MODULE_big = dblink
+-PG_CPPFLAGS = -I$(libpq_srcdir)
++PG_CPPFLAGS = -I$(libpq_srcdir) -I../../src/include/
+ OBJS = dblink.o
+ SHLIB_LINK = $(libpq)
+
+diff -Naur postgresql-9.0.3.orig/contrib/Makefile postgresql-9.0.3/contrib/Makefile
+--- postgresql-9.0.3.orig/contrib/Makefile 2011-02-02 07:37:16.654175660 -0500
++++ postgresql-9.0.3/contrib/Makefile 2011-02-06 19:04:09.240560001 -0500
+@@ -23,7 +23,6 @@
+ isn \
+ lo \
+ ltree \
+- oid2name \
+ pageinspect \
+ passwordcheck \
+ pg_archivecleanup \
+@@ -34,7 +33,6 @@
+ pg_trgm \
+ pg_upgrade \
+ pg_upgrade_support \
+- pgbench \
+ pgcrypto \
+ pgrowlocks \
+ pgstattuple \
+@@ -43,8 +41,7 @@
+ tablefunc \
+ test_parser \
+ tsearch2 \
+- unaccent \
+- vacuumlo
++ unaccent
+
+ ifeq ($(with_openssl),yes)
+ SUBDIRS += sslinfo
+diff -Naur postgresql-9.0.3.orig/contrib/uuid-ossp/Makefile postgresql-9.0.3/contrib/uuid-ossp/Makefile
+--- postgresql-9.0.3.orig/contrib/uuid-ossp/Makefile 2011-02-02 07:37:26.354099087 -0500
++++ postgresql-9.0.3/contrib/uuid-ossp/Makefile 2011-02-06 18:50:15.566945002 -0500
+@@ -1,11 +1,12 @@
+ # $PostgreSQL: pgsql/contrib/uuid-ossp/Makefile,v 1.4 2007/11/13 00:13:19 tgl Exp $
++PG_CPPFLAGS += "-DHAVE_OSSP_UUID_H"
+
+ MODULE_big = uuid-ossp
+ OBJS = uuid-ossp.o
+ DATA_built = uuid-ossp.sql
+ DATA = uninstall_uuid-ossp.sql
+
+-SHLIB_LINK += $(OSSP_UUID_LIBS)
++SHLIB_LINK += -lossp-uuid
+
+ ifdef USE_PGXS
+ PG_CONFIG = pg_config
+diff -Naur postgresql-9.0.3.orig/contrib/xml2/Makefile postgresql-9.0.3/contrib/xml2/Makefile
+--- postgresql-9.0.3.orig/contrib/xml2/Makefile 2011-02-02 07:37:26.444099780 -0500
++++ postgresql-9.0.3/contrib/xml2/Makefile 2011-02-06 18:53:04.816945002 -0500
+@@ -4,7 +4,8 @@
+
+ OBJS = xpath.o xslt_proc.o
+
+-SHLIB_LINK += $(filter -lxslt, $(LIBS)) $(filter -lxml2, $(LIBS))
++PG_CPPFLAGS = $(shell xml2-config --cflags)
++SHLIB_LINK += $(shell xml2-config --libs) $(shell xslt-config --libs)
+
+ DATA_built = pgxml.sql
+ DATA = uninstall_pgxml.sql
+diff -Naur postgresql-9.0.3.orig/GNUmakefile.in postgresql-9.0.3/GNUmakefile.in
+--- postgresql-9.0.3.orig/GNUmakefile.in 2011-02-02 07:37:14.644191250 -0500
++++ postgresql-9.0.3/GNUmakefile.in 2011-02-06 18:55:44.316945002 -0500
+@@ -10,7 +10,6 @@
+
+ all:
+ $(MAKE) -C src all
+- $(MAKE) -C config all
+ @echo "All of PostgreSQL successfully made. Ready to install."
+
+ docs:
+@@ -28,7 +27,6 @@
+
+ install:
+ $(MAKE) -C src $@
+- $(MAKE) -C config $@
+ @echo "PostgreSQL installation complete."
+
+ install-docs:
+@@ -44,7 +42,6 @@
+ installdirs uninstall coverage:
+ $(MAKE) -C doc $@
+ $(MAKE) -C src $@
+- $(MAKE) -C config $@
+
+ distprep:
+ $(MAKE) -C doc $@
+diff -Naur postgresql-9.0.3.orig/src/bin/initdb/Makefile postgresql-9.0.3/src/bin/initdb/Makefile
+--- postgresql-9.0.3.orig/src/bin/initdb/Makefile 2011-02-02 07:38:35.193570971 -0500
++++ postgresql-9.0.3/src/bin/initdb/Makefile 2011-02-06 18:57:13.786945002 -0500
+@@ -16,7 +16,7 @@
+ top_builddir = ../../..
+ include $(top_builddir)/src/Makefile.global
+
+-override CPPFLAGS := -DFRONTEND -I$(libpq_srcdir) $(CPPFLAGS)
++override CPPFLAGS := -DFRONTEND -I$(top_srcdir)/src/interfaces/libpq $(CPPFLAGS)
+
+ OBJS= initdb.o encnames.o pqsignal.o $(WIN32RES)
+
+diff -Naur postgresql-9.0.3.orig/src/bin/Makefile postgresql-9.0.3/src/bin/Makefile
+--- postgresql-9.0.3.orig/src/bin/Makefile 2011-02-02 07:38:35.133570047 -0500
++++ postgresql-9.0.3/src/bin/Makefile 2011-02-06 18:58:37.556945000 -0500
+@@ -13,8 +13,7 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-SUBDIRS = initdb pg_ctl pg_dump \
+- psql scripts pg_config pg_controldata pg_resetxlog
++SUBDIRS = initdb pg_ctl pg_controldata pg_resetxlog
+ ifeq ($(PORTNAME), win32)
+ SUBDIRS+=pgevent
+ endif
+diff -Naur postgresql-9.0.3.orig/src/include/pg_config_manual.h postgresql-9.0.3/src/include/pg_config_manual.h
+--- postgresql-9.0.3.orig/src/include/pg_config_manual.h 2011-02-02 07:38:45.143493902 -0500
++++ postgresql-9.0.3/src/include/pg_config_manual.h 2011-02-06 18:59:24.906945001 -0500
+@@ -141,7 +141,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "@GENTOO_POTAGE_EPREFIX@/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+diff -Naur postgresql-9.0.3.orig/src/Makefile postgresql-9.0.3/src/Makefile
+--- postgresql-9.0.3.orig/src/Makefile 2011-02-02 07:37:56.283870942 -0500
++++ postgresql-9.0.3/src/Makefile 2011-02-06 19:00:45.076945001 -0500
+@@ -19,15 +19,12 @@
+ $(MAKE) -C backend $@
+ $(MAKE) -C backend/utils/mb/conversion_procs $@
+ $(MAKE) -C backend/snowball $@
+- $(MAKE) -C include $@
+- $(MAKE) -C interfaces $@
+ $(MAKE) -C backend/replication/libpqwalreceiver $@
+ $(MAKE) -C bin $@
+ $(MAKE) -C pl $@
+- $(MAKE) -C makefiles $@
+ $(MAKE) -C test/regress $@
+
+-install: install-local
++install:
+
+ install-local: installdirs-local
+ $(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
+diff -Naur postgresql-9.0.3.orig/src/Makefile.global.in postgresql-9.0.3/src/Makefile.global.in
+--- postgresql-9.0.3.orig/src/Makefile.global.in 2011-02-02 07:37:56.313868792 -0500
++++ postgresql-9.0.3/src/Makefile.global.in 2011-02-06 19:02:14.716945002 -0500
+@@ -458,6 +458,7 @@
+ LDFLAGS += $(PROFILE)
+ endif
+
++CFLAGS += -I$(top_srcdir)/src/include
+
+ ##########################################################################
+ #
+diff -Naur postgresql-9.0.3.orig/src/port/Makefile postgresql-9.0.3/src/port/Makefile
+--- postgresql-9.0.3.orig/src/port/Makefile 2011-02-02 07:38:59.183388185 -0500
++++ postgresql-9.0.3/src/port/Makefile 2011-02-06 19:04:00.876945002 -0500
+@@ -39,11 +39,10 @@
+ # foo_srv.o and foo.o are both built from foo.c, but only foo.o has -DFRONTEND
+ OBJS_SRV = $(OBJS:%.o=%_srv.o)
+
+-all: libpgport.a libpgport_srv.a
++all: libpgport_srv.a
+
+ # libpgport is needed by some contrib
+-install: all installdirs
+- $(INSTALL_STLIB) libpgport.a '$(DESTDIR)$(libdir)/libpgport.a'
++install:
+
+ installdirs:
+ $(MKDIR_P) '$(DESTDIR)$(libdir)'