aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-03-20 15:01:45 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2011-03-20 15:01:45 -0400
commite7af6260f08f93298c4375ee09c073296d3851f8 (patch)
treef9c31ccf7fd500ba62037c5090292f6c8229d9e0
parentInitial commit of 8.4 patches (diff)
downloadpatches-e7af6260f08f93298c4375ee09c073296d3851f8.tar.gz
patches-e7af6260f08f93298c4375ee09c073296d3851f8.tar.bz2
patches-e7af6260f08f93298c4375ee09c073296d3851f8.zip
Added LDFLAGS fix.
-rw-r--r--postgresql-8.4-server.patch9
1 files changed, 9 insertions, 0 deletions
diff --git a/postgresql-8.4-server.patch b/postgresql-8.4-server.patch
index f59a719..0098566 100644
--- a/postgresql-8.4-server.patch
+++ b/postgresql-8.4-server.patch
@@ -171,6 +171,15 @@ diff -Naur a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
/*
* The random() function is expected to yield values between 0 and
+diff -Naur a/src/makefiles/Makefile.linux b/src/makefiles/Makefile.linux
+--- a/src/makefiles/Makefile.linux 2011-01-27 21:23:36.000000000 -0500
++++ b/src/makefiles/Makefile.linux 2011-03-20 14:58:42.743200540 -0400
+@@ -11,4 +11,4 @@
+ endif
+
+ %.so: %.o
+- $(CC) $(CFLAGS) -shared -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@ $<
diff -Naur a/src/port/Makefile b/src/port/Makefile
--- a/src/port/Makefile 2011-01-27 21:23:36.000000000 -0500
+++ b/src/port/Makefile 2011-03-20 14:49:33.936295541 -0400