summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-client/files/postgresql-7.4-client.patch')
-rw-r--r--dev-db/postgresql-client/files/postgresql-7.4-client.patch155
1 files changed, 0 insertions, 155 deletions
diff --git a/dev-db/postgresql-client/files/postgresql-7.4-client.patch b/dev-db/postgresql-client/files/postgresql-7.4-client.patch
deleted file mode 100644
index 59008c6..0000000
--- a/dev-db/postgresql-client/files/postgresql-7.4-client.patch
+++ /dev/null
@@ -1,155 +0,0 @@
-diff --git a/contrib/Makefile b/contrib/Makefile
-index 74310cf..7d7da92 100644
---- a/contrib/Makefile
-+++ b/contrib/Makefile
-@@ -5,41 +5,11 @@ top_builddir = ..
- include $(top_builddir)/src/Makefile.global
-
- WANTED_DIRS = \
-- btree_gist \
-- chkpass \
-- cube \
-- dbase \
-- dblink \
-- dbmirror \
-- dbsize \
-- earthdistance \
- findoidjoins \
-- fulltextindex \
-- fuzzystrmatch \
-- intagg \
-- intarray \
-- isbn_issn \
-- lo \
-- ltree \
-- miscutil \
-- noupdate \
- oid2name \
- pg_autovacuum \
- pg_dumplo \
-- pg_logger \
- pgbench \
-- pgcrypto \
-- pgstattuple \
-- rserv \
-- rtree_gist \
-- seg \
-- spi \
-- string \
-- tablefunc \
-- tips \
-- tsearch \
-- tsearch2 \
-- userlock \
- vacuumlo
-
- # Missing:
-diff --git a/src/Makefile b/src/Makefile
-index cd6e5e6..f0bee6f 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -14,16 +14,9 @@ include Makefile.global
-
-
- all install installdirs uninstall dep depend distprep:
-- $(MAKE) -C port $@
-- $(MAKE) -C backend $@
-- $(MAKE) -C backend/utils/mb/conversion_procs $@
-- $(MAKE) -C include $@
-- $(MAKE) -C interfaces $@
- $(MAKE) -C bin $@
-- $(MAKE) -C pl $@
-
- install-all-headers:
-- $(MAKE) -C include $@
-
- clean:
- $(MAKE) -C port $@
-diff --git a/src/Makefile.global.in b/src/Makefile.global.in
-index 19c49d1..af4af77 100644
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -287,14 +287,16 @@ endif
- # Some variables needed to find some client interfaces
-
- libpq_srcdir = $(top_srcdir)/src/interfaces/libpq
--libpq_builddir = $(top_builddir)/src/interfaces/libpq
--libpq = -L$(libpq_builddir) -lpq
-+#libpq_builddir = $(top_builddir)/src/interfaces/libpq
-+libpq_builddir = -I/usr/include/postgresql-${SLOT}/libpq
-+#libpq = -L$(libpq_builddir) -lpq
-+libpq = -L/usr/lib/postgresql-${SLOT}/lib -lpq
-
- submake-libpq:
-- $(MAKE) -C $(libpq_builddir) all
-+ @true $(MAKE) -C $(libpq_builddir) all
-
- submake-libpgport:
-- $(MAKE) -C $(top_builddir)/src/port all
-+ @true $(MAKE) -C $(top_builddir)/src/port all
-
- .PHONY: submake-libpq submake-libpgport
-
-diff --git a/src/backend/parser/Makefile b/src/backend/parser/Makefile
-index b6698d2..81fa31c 100644
---- a/src/backend/parser/Makefile
-+++ b/src/backend/parser/Makefile
-@@ -10,7 +10,7 @@ subdir = src/backend/parser
- top_builddir = ../../..
- include $(top_builddir)/src/Makefile.global
-
--override CPPFLAGS := -I$(srcdir) $(CPPFLAGS)
-+override CPPFLAGS := -I. -I.. $(CPPFLAGS)
-
- OBJS= analyze.o gram.o keywords.o parser.o parse_agg.o parse_clause.o \
- parse_expr.o parse_func.o parse_node.o parse_oper.o parse_relation.o \
-diff --git a/src/bin/Makefile b/src/bin/Makefile
-index 3035f61..fb889fb 100644
---- a/src/bin/Makefile
-+++ b/src/bin/Makefile
-@@ -13,9 +13,8 @@ subdir = src/bin
- top_builddir = ../..
- include $(top_builddir)/src/Makefile.global
-
--DIRS := initdb initlocation ipcclean pg_ctl pg_dump pg_id \
-- psql scripts pg_config pg_controldata pg_resetxlog \
-- pg_encoding
-+DIRS := pg_dump \
-+ psql scripts
-
- ifeq ($(with_tcl), yes)
- DIRS += pgtclsh
-diff --git a/src/bin/pg_dump/Makefile b/src/bin/pg_dump/Makefile
-index 5594593..927d367 100644
---- a/src/bin/pg_dump/Makefile
-+++ b/src/bin/pg_dump/Makefile
-@@ -24,13 +24,13 @@ override CPPFLAGS := -I$(libpq_srcdir) $(CPPFLAGS) -DBINDIR=\"$(bindir)\"
-
- all: submake-libpq submake-libpgport submake-backend pg_dump pg_restore pg_dumpall
-
--pg_dump: pg_dump.o common.o $(OBJS) $(libpq_builddir)/libpq.a
-+pg_dump: pg_dump.o common.o $(OBJS)
- $(CC) $(CFLAGS) pg_dump.o common.o $(OBJS) $(EXTRA_OBJS) $(libpq) $(LDFLAGS) $(LIBS) -o $@
-
--pg_restore: pg_restore.o $(OBJS) $(libpq_builddir)/libpq.a
-+pg_restore: pg_restore.o $(OBJS)
- $(CC) $(CFLAGS) pg_restore.o $(OBJS) $(EXTRA_OBJS) $(libpq) $(LDFLAGS) $(LIBS) -o $@
-
--pg_dumpall: pg_dumpall.o $(libpq_builddir)/libpq.a
-+pg_dumpall: pg_dumpall.o
- $(CC) $(CFLAGS) pg_dumpall.o dumputils.o $(EXTRA_OBJS) $(libpq) $(LDFLAGS) $(LIBS) -o $@
-
- .PHONY: submake-backend
-diff --git a/src/bin/psql/Makefile b/src/bin/psql/Makefile
-index e8afcf6..e70a8bf 100644
---- a/src/bin/psql/Makefile
-+++ b/src/bin/psql/Makefile
-@@ -23,7 +23,7 @@ OBJS= command.o common.o help.o input.o stringutils.o mainloop.o copy.o \
-
- all: submake-libpq submake-libpgport psql
-
--psql: $(OBJS) $(libpq_builddir)/libpq.a
-+psql: $(OBJS)
- $(CC) $(CFLAGS) $(OBJS) $(libpq) $(LDFLAGS) $(LIBS) -o $@
-
- help.o: $(srcdir)/sql_help.h