aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2015-07-09 11:26:58 -0400
committerTim Harder <radhermit@gmail.com>2015-07-09 11:30:21 -0400
commita9e691a49ea0612990dd5736e80a0a7cdae7d454 (patch)
tree630260feff80361c95142ccb05072560ad573bf1
parentgenerate bash function lists for the dist tarball (diff)
downloadpkgcore-a9e691a49ea0612990dd5736e80a0a7cdae7d454.tar.gz
pkgcore-a9e691a49ea0612990dd5736e80a0a7cdae7d454.tar.bz2
pkgcore-a9e691a49ea0612990dd5736e80a0a7cdae7d454.zip
test: drop global function list test
It's now generated on demand at sdist and install time.
-rw-r--r--pkgcore/test/ebuild/test_ebd.py39
1 files changed, 0 insertions, 39 deletions
diff --git a/pkgcore/test/ebuild/test_ebd.py b/pkgcore/test/ebuild/test_ebd.py
deleted file mode 100644
index c34b8bd7..00000000
--- a/pkgcore/test/ebuild/test_ebd.py
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright: 2011 Brian Harring <ferringb@gmail.com>
-# License: GPL2/BSD
-
-import subprocess
-import sys
-
-from snakeoil.osutils import pjoin
-
-from pkgcore.ebuild import const
-from pkgcore.test import TestCase
-
-
-class Test_DontExportFuncsList(TestCase):
- base_path = const.EAPI_BIN_PATH
-
- def test_list_is_upto_date(self):
-
- with open(pjoin(self.base_path, "dont_export_funcs.list")) as f:
- existing = set(x.strip() for x in f)
-
- ppath = ":".join(sys.path)
- proc = subprocess.Popen([pjoin(self.base_path,
- "regenerate_dont_export_func_list.bash"), "-"],
- stdout=subprocess.PIPE,
- stderr=subprocess.PIPE,
- env={"PKGCORE_PYTHON_PATH":ppath},
- close_fds=True)
-
- self.assertEqual(proc.wait(), 0)
- current = set(x.strip().decode("ascii") for x in proc.stdout.read().split())
-
- missing = current.difference(existing)
- unneeded = existing.difference(current)
-
- stderr = proc.stderr.read()
- self.assertEqual(current, existing,
- msg="ondisk dont_export_funcs.list is out of date from the actual source"
- "\nmissing is %r\nuneeded is %r\nstderr was:\n%s" %
- (sorted(missing), sorted(unneeded), stderr))