aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2015-07-11 21:11:33 -0400
committerTim Harder <radhermit@gmail.com>2015-07-12 00:37:54 -0400
commit84e87863faa142f7d5ad0806124ec7a3c6cc1adf (patch)
tree7e8a8019e55332f222f5a6574fd7fd63e286d5fa
parentportage_conf: drop 'domain' from domain config object name (diff)
downloadpkgcore-84e87863faa142f7d5ad0806124ec7a3c6cc1adf.tar.gz
pkgcore-84e87863faa142f7d5ad0806124ec7a3c6cc1adf.tar.bz2
pkgcore-84e87863faa142f7d5ad0806124ec7a3c6cc1adf.zip
setup: assume all symlinks in the bin dir are scripts to install
That way we can add other files in there or change the pwrapper* file names if needed without breaking things.
-rwxr-xr-xsetup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 2a60ef268..e85fa3b24 100755
--- a/setup.py
+++ b/setup.py
@@ -28,6 +28,9 @@ DATA_INSTALL_OFFSET = 'share/pkgcore'
CONFIG_INSTALL_OFFSET = os.path.join(DATA_INSTALL_OFFSET, 'config')
EBD_INSTALL_OFFSET = 'lib/pkgcore'
+# top level repo/tarball directory
+TOPDIR = os.path.dirname(os.path.abspath(__file__))
+
class mysdist(snk_distutils.sdist):
@@ -155,7 +158,7 @@ class pkgcore_install_scripts(Command):
('skip_build', 'skip_build'),
)
self.scripts = [path for path in os.listdir('bin')
- if path not in ('pwrapper', 'pwrapper_installed')]
+ if os.path.islink(os.path.join(TOPDIR, 'bin', path))]
def run(self):
if not self.skip_build:
@@ -248,9 +251,8 @@ class pkgcore_install_docs(Command):
self.prefix, 'share', 'doc', 'pkgcore-%s' % version, 'html')
def find_content(self):
- cwd = os.path.dirname(os.path.abspath(__file__))
for possible_path in self.content_search_path:
- possible_path = os.path.join(cwd, possible_path)
+ possible_path = os.path.join(TOPDIR, possible_path)
if os.path.isdir(possible_path):
return possible_path
else: