aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meson.build8
-rw-r--r--security.c4
2 files changed, 11 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0cb9a0e..255107b 100644
--- a/meson.build
+++ b/meson.build
@@ -166,6 +166,12 @@ if do_tests and get_option('use_fuzzing')
link_args : fuzz_flags,
install : false
)
- test('fuzz-dumpelf', dumpelf_fuzzer)
+ test('fuzz-dumpelf', dumpelf_fuzzer,
+ args : [
+ '-close_fd_mask=3',
+ '-max_total_time=10',
+ '-print_final_stats',
+ ]
+ )
endif
endif
diff --git a/security.c b/security.c
index 19bf78f..7122a7f 100644
--- a/security.c
+++ b/security.c
@@ -46,6 +46,10 @@
# undef WANT_SECCOMP
#endif
+#if PAX_UTILS_LIBFUZZ
+# undef WANT_SECCOMP
+#endif
+
static int ns_unshare(int flags)
{
int flag, ret = 0;