aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-12-29 10:19:03 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-12-29 10:19:17 -0500
commit7850b6efbe383aec9b63d9ed44e2af8d845ee261 (patch)
tree1ea6197c01d6e52de65676e6a519c219b059fe37
parentapp-arch/pax: stable (diff)
downloadmusl-7850b6efbe383aec9b63d9ed44e2af8d845ee261.tar.gz
musl-7850b6efbe383aec9b63d9ed44e2af8d845ee261.tar.bz2
musl-7850b6efbe383aec9b63d9ed44e2af8d845ee261.zip
app-arch/pax: in tree version works
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--app-arch/pax/Manifest1
-rw-r--r--app-arch/pax/files/pax-20160306-glibc-to-linux.patch38
-rw-r--r--app-arch/pax/metadata.xml5
-rw-r--r--app-arch/pax/pax-20161104.ebuild61
4 files changed, 0 insertions, 105 deletions
diff --git a/app-arch/pax/Manifest b/app-arch/pax/Manifest
deleted file mode 100644
index a31ca15a..00000000
--- a/app-arch/pax/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST paxmirabilis-20161104.cpio.gz 148061 BLAKE2B 997a126d3048488e1a4e49ff9753de2ebdbe75b7daedbea8c95ab5f1902d4768d4b12b13fa684cb2a7c2fe8470ab60e19ea3f9430429a6a4e6e1d57993130fd4 SHA512 42ec8365a5efb9ffb9d383cece39ffaac85c1c8d69856ec557a5567cf0d28d98a0f2d4b7fed53572366eba12c71111cc80b591d51c6a19a3e6437efb62af33ce
diff --git a/app-arch/pax/files/pax-20160306-glibc-to-linux.patch b/app-arch/pax/files/pax-20160306-glibc-to-linux.patch
deleted file mode 100644
index f864729c..00000000
--- a/app-arch/pax/files/pax-20160306-glibc-to-linux.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- pax/cache.c.old 2016-03-06 08:12:52.000000000 -0600
-+++ pax/cache.c 2016-04-17 13:01:26.461307830 -0500
-@@ -195,7 +195,7 @@
- * No entry for this uid, we will add it
- */
- if (!pwopn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setpwent();
- #elif !defined(__INTERIX)
- setpassent(1);
-@@ -265,7 +265,7 @@
- * No entry for this gid, we will add it
- */
- if (!gropn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setgrent();
- #elif !defined(__INTERIX) && !defined(__CYGWIN__)
- setgroupent(1);
-@@ -336,7 +336,7 @@
- }
-
- if (!pwopn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setpwent();
- #elif !defined(__INTERIX)
- setpassent(1);
-@@ -403,7 +403,7 @@
- }
-
- if (!gropn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setgrent();
- #elif !defined(__INTERIX) && !defined(__CYGWIN__)
- setgroupent(1);
diff --git a/app-arch/pax/metadata.xml b/app-arch/pax/metadata.xml
deleted file mode 100644
index 6f49eba8..00000000
--- a/app-arch/pax/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/app-arch/pax/pax-20161104.ebuild b/app-arch/pax/pax-20161104.ebuild
deleted file mode 100644
index a280ff05..00000000
--- a/app-arch/pax/pax-20161104.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit unpacker toolchain-funcs
-
-DESCRIPTION="pax (Portable Archive eXchange) is the POSIX standard archive tool"
-HOMEPAGE="https://www.mirbsd.org/pax.htm"
-SRC_URI="https://www.mirbsd.org/MirOS/dist/mir/cpio/paxmirabilis-${PV}.cpio.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc x86"
-
-RDEPEND="
- dev-libs/libbsd
- elibc_musl? ( sys-libs/fts-standalone )
-"
-DEPEND="
- ${RDEPEND}
- $(unpacker_src_uri_depends)
-"
-PATCHES=(
- "${FILESDIR}/${PN}-20160306-glibc-to-linux.patch"
-)
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- # Newer C libraries omit this include from sys/types.h.
- sed -i '1i#include <sys/sysmacros.h>' extern.h || die
- default
-}
-
-src_configure() {
- tc-export CC PKG_CONFIG
-}
-
-src_compile() {
- # We can't rely on LFS flags as it uses the fts.h interface which lacks 64-bit support.
- set -- \
- ${CC} ${CPPFLAGS} ${CFLAGS} \
- -DPAX_SAFE_PATH=\"/bin:/usr/bin\" \
- -DHAVE_STRLCPY -DHAVE_VIS -DHAVE_STRMODE \
- -DLONG_OFF_T -DHAVE_LINKAT \
- $(${PKG_CONFIG} --cflags libbsd-overlay) \
- -Wall ${LDFLAGS} *.c -o ${PN} $(usex elibc_musl '-lfts' '')\
- $(${PKG_CONFIG} --libs libbsd-overlay)
- echo "$@"
- "$@" || die
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
-
- dosym pax /usr/bin/paxcpio
- newman cpio.1 paxcpio.1
-
- dosym pax /usr/bin/paxtar
- newman tar.1 paxtar.1
-}