summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2017-07-24 08:39:38 -0500
committerJory A. Pratt <anarchy@gentoo.org>2017-07-24 08:39:38 -0500
commit283f718dc0da4cf9a8a18b480da55905c45b7799 (patch)
treedfea622fde5cf2cc70e858087731411b432626d7
parentwww-client/firefox: 55.0_beta11 bump (diff)
downloadmozilla-283f718dc0da4cf9a8a18b480da55905c45b7799.tar.gz
mozilla-283f718dc0da4cf9a8a18b480da55905c45b7799.tar.bz2
mozilla-283f718dc0da4cf9a8a18b480da55905c45b7799.zip
x11-plugins/enigmail: version bump to 1.9.8.1
-rw-r--r--x11-plugins/enigmail/Manifest1
-rw-r--r--x11-plugins/enigmail/enigmail-1.9.8.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
new file mode 100644
index 00000000..b50bc145
--- /dev/null
+++ b/x11-plugins/enigmail/Manifest
@@ -0,0 +1 @@
+DIST enigmail-1.9.8.1.tar.gz 1776673 SHA256 4bcf2da00d96a67921b24dbec9f43930cba41112a2cd241b0952eb573c648a4d SHA512 af280040e96eb69529e723e52e65621e42743c974b0ed42598e73458004f0a59688da7257d2b556e95a56c4cad3ac48f527d4d9a7a54c9c92eaff132257e0cfd WHIRLPOOL 077c61b996c2ec45ecc3a037b61d167acda2ebdbde6536e2f2f2e180a064c9e540e09b48417454aa48f02af5f4c58c88f4ba456e6c5f113cfe474f2b82798ac0
diff --git a/x11-plugins/enigmail/enigmail-1.9.8.1.ebuild b/x11-plugins/enigmail/enigmail-1.9.8.1.ebuild
new file mode 100644
index 00000000..6f84834d
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-1.9.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="http://www.enigmail.net/"
+
+KEYWORDS="~alpha amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt4(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake ipc public ui package lang
+ emake xpi
+
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r build/dist/{chrome,components,defaults,modules,wrappers,chrome.manifest,install.rdf}
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+}