summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2014-04-15 18:06:50 -0500
committerJory A. Pratt <anarchy@gentoo.org>2014-04-15 18:06:50 -0500
commit564810b6330ef701e50d1f46e8a7719bba512977 (patch)
tree6154509afac56fa15127c407ce16fd47055e6add
parentAdd hardened useflag and append relro ldflags, bug #500186 (diff)
downloadmozilla-564810b6330ef701e50d1f46e8a7719bba512977.tar.gz
mozilla-564810b6330ef701e50d1f46e8a7719bba512977.tar.bz2
mozilla-564810b6330ef701e50d1f46e8a7719bba512977.zip
add hardened relro support
-rw-r--r--mail-client/thunderbird/thunderbird-24.4.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/mail-client/thunderbird/thunderbird-24.4.0.ebuild b/mail-client/thunderbird/thunderbird-24.4.0.ebuild
index c5a85648..34222db2 100644
--- a/mail-client/thunderbird/thunderbird-24.4.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-24.4.0.ebuild
@@ -36,7 +36,7 @@ HOMEPAGE="http://www.mozilla.com/en-US/thunderbird/"
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist crypt gstreamer +jit ldap +lightning +minimal mozdom pulseaudio selinux system-cairo system-icu system-jpeg system-sqlite"
+IUSE="bindist crypt gstreamer hardened +jit ldap +lightning +minimal mozdom pulseaudio selinux system-cairo system-icu system-jpeg system-sqlite"
PATCH="thunderbird-24.0-patches-0.1"
PATCHFF="firefox-24.0-patches-0.9"
@@ -205,6 +205,9 @@ src_configure() {
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"
+ # Add full relro support for hardened
+ use hardened && append-ldflags "-Wl,-z,relro,-z,now"
+
# We must force enable jemalloc 3 threw .mozconfig
echo "export MOZ_JEMALLOC=1" >> ${S}/.mozconfig