summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-11-11 10:32:04 -0500
committerMike Pagano <mpagano@gentoo.org>2020-11-11 10:32:04 -0500
commit46c17fd394681821cb3a4be0ed1b94f5c6fe0de5 (patch)
tree629814aea92a431f47cd036471ecef16a0d4985f
parentLinux patch 4.9.242 (diff)
downloadlinux-patches-46c17fd394681821cb3a4be0ed1b94f5c6fe0de5.tar.gz
linux-patches-46c17fd394681821cb3a4be0ed1b94f5c6fe0de5.tar.bz2
linux-patches-46c17fd394681821cb3a4be0ed1b94f5c6fe0de5.zip
Linux patch 4.9.2434.9-247
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1242_linux-4.9.243.patch28
2 files changed, 32 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index bee8e2e8..4546eb0b 100644
--- a/0000_README
+++ b/0000_README
@@ -1011,6 +1011,10 @@ Patch: 1241_linux-4.9.242.patch
From: http://www.kernel.org
Desc: Linux 4.9.242
+Patch: 1242_linux-4.9.243.patch
+From: http://www.kernel.org
+Desc: Linux 4.9.243
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1242_linux-4.9.243.patch b/1242_linux-4.9.243.patch
new file mode 100644
index 00000000..0b7845a2
--- /dev/null
+++ b/1242_linux-4.9.243.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index d41de2c1159e7..c6fcfe4bfeed5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 9
+-SUBLEVEL = 242
++SUBLEVEL = 243
+ EXTRAVERSION =
+ NAME = Roaring Lionus
+
+diff --git a/drivers/powercap/powercap_sys.c b/drivers/powercap/powercap_sys.c
+index 5b10b50f8686f..5c064df7d81f1 100644
+--- a/drivers/powercap/powercap_sys.c
++++ b/drivers/powercap/powercap_sys.c
+@@ -379,9 +379,9 @@ static void create_power_zone_common_attributes(
+ &dev_attr_max_energy_range_uj.attr;
+ if (power_zone->ops->get_energy_uj) {
+ if (power_zone->ops->reset_energy_uj)
+- dev_attr_energy_uj.attr.mode = S_IWUSR | S_IRUGO;
++ dev_attr_energy_uj.attr.mode = S_IWUSR | S_IRUSR;
+ else
+- dev_attr_energy_uj.attr.mode = S_IRUGO;
++ dev_attr_energy_uj.attr.mode = S_IRUSR;
+ power_zone->zone_dev_attrs[count++] =
+ &dev_attr_energy_uj.attr;
+ }