summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-06-27 07:08:41 -0400
committerMike Pagano <mpagano@gentoo.org>2019-10-29 09:59:02 -0400
commit758f68a620c6ad46ec76f4e7b0ca2416aec7da68 (patch)
treed99338708bffc4df172f94bf03952a09eb341104
parentLinux patch 4.14.130 (diff)
downloadlinux-patches-758f68a620c6ad46ec76f4e7b0ca2416aec7da68.tar.gz
linux-patches-758f68a620c6ad46ec76f4e7b0ca2416aec7da68.tar.bz2
linux-patches-758f68a620c6ad46ec76f4e7b0ca2416aec7da68.zip
Linux patch 4.14.131
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1130_linux-4.14.131.patch26
2 files changed, 30 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 5805bb99..562acb4f 100644
--- a/0000_README
+++ b/0000_README
@@ -563,6 +563,10 @@ Patch: 1129_linux-4.14.130.patch
From: https://www.kernel.org
Desc: Linux 4.14.130
+Patch: 1130_linux-4.14.131.patch
+From: https://www.kernel.org
+Desc: Linux 4.14.131
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1130_linux-4.14.131.patch b/1130_linux-4.14.131.patch
new file mode 100644
index 00000000..167fb1bb
--- /dev/null
+++ b/1130_linux-4.14.131.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index 9d0715c300b1..275343cf27f7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 4
+ PATCHLEVEL = 14
+-SUBLEVEL = 130
++SUBLEVEL = 131
+ EXTRAVERSION =
+ NAME = Petit Gorille
+
+diff --git a/net/ipv4/tcp_output.c b/net/ipv4/tcp_output.c
+index a8772e11dc1c..a5960b9b6741 100644
+--- a/net/ipv4/tcp_output.c
++++ b/net/ipv4/tcp_output.c
+@@ -1274,7 +1274,7 @@ int tcp_fragment(struct sock *sk, struct sk_buff *skb, u32 len,
+ if (nsize < 0)
+ nsize = 0;
+
+- if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf)) {
++ if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf + 0x20000)) {
+ NET_INC_STATS(sock_net(sk), LINUX_MIB_TCPWQUEUETOOBIG);
+ return -ENOMEM;
+ }