aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-09-12 11:25:51 -0600
committerEric Blake <eblake@redhat.com>2012-09-12 11:27:22 -0600
commita20f06d9d9b0353d7fb7a8e11a631253d5961b96 (patch)
tree680af104c65ba382eb37c9ac008f843699009d38 /tests
parentAdd API for opening a QEMU monitor from a socket FD (diff)
downloadlibvirt-a20f06d9d9b0353d7fb7a8e11a631253d5961b96.tar.gz
libvirt-a20f06d9d9b0353d7fb7a8e11a631253d5961b96.tar.bz2
libvirt-a20f06d9d9b0353d7fb7a8e11a631253d5961b96.zip
build: avoid confusing make with raw name 'undefine'
Make has a builtin operator 'undefine', and coupled with latest automake.git, this test name ended up confusing make into thinking the file name was meant to be used as the make operator. Renaming the file avoids the confusion. * tests/undefine: Rename... * tests/virsh-undefine: ...to this. * tests/Makefile.am (test_scripts): Use new name. Reported by Jim Meyering.
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am10
-rwxr-xr-xtests/virsh-undefine (renamed from tests/undefine)0
2 files changed, 6 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bec89e20e..c5cecaa38 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -182,12 +182,13 @@ test_scripts += \
read-bufsiz \
read-non-seekable \
start \
- undefine \
vcpupin \
virsh-all \
virsh-optparse \
virsh-schedinfo \
- virsh-synopsis
+ virsh-synopsis \
+ virsh-undefine \
+ $(NULL)
test_programs += \
eventtest \
@@ -203,12 +204,13 @@ EXTRA_DIST += \
read-bufsiz \
read-non-seekable \
start \
- undefine \
vcpupin \
virsh-all \
virsh-optparse \
virsh-schedinfo \
- virsh-synopsis
+ virsh-synopsis \
+ virsh-undefine \
+ $(NULL)
endif
if WITH_SECDRIVER_APPARMOR
diff --git a/tests/undefine b/tests/virsh-undefine
index f7ba49593..f7ba49593 100755
--- a/tests/undefine
+++ b/tests/virsh-undefine