summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2006-08-29 22:27:07 +0000
committerDaniel Veillard <veillard@redhat.com>2006-08-29 22:27:07 +0000
commit3bbac7cdb670fb7e8b8fad25cfe4b23a8bf4a056 (patch)
tree900d74e5d8418835cfcfa949222e2ad7819da351 /tests/confdata
parentAdd handling of error HTTP 500 codes (diff)
downloadlibvirt-3bbac7cdb670fb7e8b8fad25cfe4b23a8bf4a056.tar.gz
libvirt-3bbac7cdb670fb7e8b8fad25cfe4b23a8bf4a056.tar.bz2
libvirt-3bbac7cdb670fb7e8b8fad25cfe4b23a8bf4a056.zip
* TODO libvirt.spec.in: update
* configure.in include/libvirt/virterror.h src/Makefile.am src/conf.c src/conf.h src/virterror.c src/xen_internal.c: adding a subset of Xen config file parser, and serializer * tests/Makefile.am tests/conftest.c tests/test_conf.sh tests/confdata/Makefile.am tests/confdata/fc4.conf tests/confdata/fc4.out: adding test program for config in and out Daniel
Diffstat (limited to 'tests/confdata')
-rw-r--r--tests/confdata/Makefile.am2
-rw-r--r--tests/confdata/fc4.conf10
-rw-r--r--tests/confdata/fc4.out10
3 files changed, 22 insertions, 0 deletions
diff --git a/tests/confdata/Makefile.am b/tests/confdata/Makefile.am
new file mode 100644
index 000000000..8393a6f2b
--- /dev/null
+++ b/tests/confdata/Makefile.am
@@ -0,0 +1,2 @@
+
+EXTRA_DIST = $(wildcard *.in) $(wildcard *.out)
diff --git a/tests/confdata/fc4.conf b/tests/confdata/fc4.conf
new file mode 100644
index 000000000..745a4c409
--- /dev/null
+++ b/tests/confdata/fc4.conf
@@ -0,0 +1,10 @@
+kernel="/boot/vmlinuz-2.6.15-1.2054_FC5xenU"
+ramdisk="/boot/initrd-2.6.15-1.2054_FC5xenU.img"
+memory=128 # should be enough
+name="fc4"
+vif = [ 'mac=aa:00:00:00:00:11, bridge=xenbr0' ]
+disk = ['file:/xen/fc4.img,sda1,w']
+root = "/dev/sda1"
+extra = "ro selinux=0 3"
+# just for testing ...
+tst = [ 1, 2, [ 3, 4 ], 5]
diff --git a/tests/confdata/fc4.out b/tests/confdata/fc4.out
new file mode 100644
index 000000000..1fad85ceb
--- /dev/null
+++ b/tests/confdata/fc4.out
@@ -0,0 +1,10 @@
+kernel = "/boot/vmlinuz-2.6.15-1.2054_FC5xenU"
+ramdisk = "/boot/initrd-2.6.15-1.2054_FC5xenU.img"
+memory = 128 # should be enough
+name = "fc4"
+vif = [ "mac=aa:00:00:00:00:11, bridge=xenbr0" ]
+disk = [ "file:/xen/fc4.img,sda1,w" ]
+root = "/dev/sda1"
+extra = "ro selinux=0 3"
+# just for testing ...
+tst = [ 1, 2, [ 3, 4 ], 5 ]