summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2012-04-14 19:18:03 +0200
committerGuido Günther <agx@sigxcpu.org>2012-04-15 11:54:20 +0200
commita2996926e303e84436a89dc42fe65d32b5ab8eb5 (patch)
tree862e7d885644c20bfa3c29d1f13da8edccbc5f43 /configure.ac
parentvirnetdev: Check for defined IFLA_VF_* (diff)
downloadlibvirt-a2996926e303e84436a89dc42fe65d32b5ab8eb5.tar.gz
libvirt-a2996926e303e84436a89dc42fe65d32b5ab8eb5.tar.bz2
libvirt-a2996926e303e84436a89dc42fe65d32b5ab8eb5.zip
Fix macvtap detection by also checking for IFLA_VF_MAX
since this isn't available on older kernels such as Debian Squeeze's 2.6.32. This make --with-macvtap=check work as expected.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3f5b3ffec..53c9b34ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2534,7 +2534,8 @@ AC_MSG_CHECKING([whether to compile with macvtap support])
if test "$with_macvtap" != "no" ; then
AC_TRY_COMPILE([ #include <sys/socket.h>
#include <linux/rtnetlink.h> ],
- [ int x = MACVLAN_MODE_BRIDGE; ],
+ [ int x = MACVLAN_MODE_BRIDGE;
+ int y = IFLA_VF_MAX; ],
[ with_macvtap=yes ],
[ if test "$with_macvtap" = "yes" ; then
AC_MSG_ERROR([Installed linux headers don't show support for macvtap device.])