summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-05-25 13:18:10 -0600
committerEric Blake <eblake@redhat.com>2012-05-28 07:19:25 -0600
commit1d22ba953b646d8681c334abd30f1a2e5441a720 (patch)
tree60d00a649d6173e329b76ee050556951d6ad3521 /configure.ac
parentFix linking to DTrace probes file (diff)
downloadlibvirt-1d22ba953b646d8681c334abd30f1a2e5441a720.tar.gz
libvirt-1d22ba953b646d8681c334abd30f1a2e5441a720.tar.bz2
libvirt-1d22ba953b646d8681c334abd30f1a2e5441a720.zip
build: silence libtool during tests
Libtool is picky about linking against a module library (aka a .so); giving lots of warnings like this in the tests directory: CCLD networkxml2argvtest *** Warning: Linking the executable networkxml2argvtest against the loadable module *** libvirt_driver_network.so is not portable! Fix that by splitting things into a convenience library which can be used directly by the tests, and making the real .so just wrap the convenience library. Based on a suggestion by Daniel P. Berrange. * configure.ac (--with-driver-modules): Fix help test. * src/Makefile.am (libvirt_driver_xen.la, libvirt_driver_libxl.la) (libvirt_driver_qemu.la, libvirt_driver_lxc.la) (libvirt_driver_uml.la): Factor into new convenience libraries. * tests/Makefile.am (xen_LDADDS, qemu_LDADDS, lxc_LDADDS) (networkxml2argvtest_LDADD): Link to convenience libraries, not shared libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ac7a13762..59962c513 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2421,7 +2421,8 @@ AM_CONDITIONAL([WITH_WIN_ICON], [test "$WINDRES" != ""])
dnl Driver-Modules library
AC_ARG_WITH([driver-modules],
- AC_HELP_STRING([--with-driver-modules], [build drivers as loadable modules @<:@default=no@:>@]),
+ AC_HELP_STRING([--with-driver-modules],
+ [build drivers as loadable modules @<:@default=check@:>@]),
[],
[with_driver_modules=check])