summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/colord-gtk/colord-gtk-9999.ebuild75
-rw-r--r--x11-libs/colord-gtk/metadata.xml8
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang111
-rw-r--r--x11-libs/gtksourceview/gtksourceview-9999.ebuild75
-rw-r--r--x11-libs/gtksourceview/metadata.xml11
5 files changed, 0 insertions, 280 deletions
diff --git a/x11-libs/colord-gtk/colord-gtk-9999.ebuild b/x11-libs/colord-gtk/colord-gtk-9999.ebuild
deleted file mode 100644
index 5b3b91fd..00000000
--- a/x11-libs/colord-gtk/colord-gtk-9999.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-VALA_MIN_API_VERSION="0.14"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils vala
-if [[ ${PV} = 9999 ]]; then
- GCONF_DEBUG="no"
- inherit gnome2-live # need all the hacks from gnome2-live_src_prepare
-fi
-
-DESCRIPTION="GTK support library for colord"
-HOMEPAGE="http://www.freedesktop.org/software/colord/"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://gitorious.org/colord/colord-gtk.git"
-else
- SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
-fi
-
-LICENSE="LGPL-3+"
-SLOT="0/1" # subslot = libcolord-gtk soname version
-IUSE="doc +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.28:2
- >=media-libs/lcms-2.2:2=
- x11-libs/gdk-pixbuf:2[introspection?]
- x11-libs/gtk+:3[X(+),introspection?]
- x11-misc/colord:=[introspection?,vala?]
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )"
-# ${PN} was part of x11-misc/colord until 0.1.22
-RDEPEND="${COMMON_DEPEND}
- !<x11-misc/colord-0.1.27
-"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- dev-libs/libxslt
- >=dev-util/intltool-0.35
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- >=dev-util/gtk-doc-1.9
- )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- use vala && vala_src_prepare
- if [[ ${PV} = 9999 ]]; then
- gnome2_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- --disable-static \
- $(use_enable doc gtk-doc) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_install() {
- default
- prune_libtool_files --modules
-}
diff --git a/x11-libs/colord-gtk/metadata.xml b/x11-libs/colord-gtk/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/x11-libs/colord-gtk/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
deleted file mode 100644
index f1e0660c..00000000
--- a/x11-libs/gtksourceview/files/2.0/gentoo.lang
+++ /dev/null
@@ -1,111 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!--
- GtkSourceView syntax highlight for Gentoo-specific files
-
- Originally written for gtksourceview-1.x by:
- Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
- Rewritten for gtksourceview-2 by:
- Rene 'Necoro' Neumann <necoro@necoro.net>, 2007
-
- Distributed under the same license(s) as gtksourceview.
-
- TODO:
- - do not highlight "enable" in the configure options
- - perhaps highlight portage variables and portage functions different
-
--->
-
-<language name="gentoo" id="gentoo" version="2.0" _section="Scripts">
- <metadata>
- <property name="globs">*.ebuild;*.eclass</property>
- <property name="line-comment-start">#</property>
- </metadata>
-
- <styles>
- <style id="variable" _name="Portage variables" map-to="def:builtin" />
- <style id="command" _name="Portage command" map-to="def:type" />
- <style id="function" _name="Portage function" map-to="def:function" />
- <style id="string" _name="String" map-to="def:string" />
- </styles>
-
- <definitions>
-
- <!-- rewrite shell string to show highlighted variables -->
- <context id="string" style-ref="def:string">
- <start>"</start>
- <end>"</end>
- <include>
- <context ref="def:escape"/>
- <context ref="def:line-continue"/>
- <context ref="sh:variable"/>
- </include>
- </context>
-
- <context id="string-2" style-ref="def:string">
- <start>'</start>
- <end>'</end>
- <include>
- <context ref="def:escape"/>
- <context ref="def:line-continue"/>
- <context ref="sh:variable"/>
- </include>
- </context>
-
- <!-- subprograms:
- - $(..) is not supported currently in the normal sh.lang
- - `...` is interpreted as string - I think the subshell behavior is more acurate -->
- <context id="subprogram">
- <start>\$\(</start>
- <end>\)</end>
- <include>
- <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
- <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
- <context ref="gentoo"/>
- </include>
- </context>
-
- <context id="subprogram-2">
- <start>`</start>
- <end>`</end>
- <include>
- <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
- <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
- <context ref="gentoo"/>
- </include>
- </context>
-
- <!-- portage variables - currently unused -->
- <context id="portvars" style-ref="variable">
- <match>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</match>
- </context>
-
- <!-- portage functions - currently unused -->
- <context id="portfuncs" style-ref="function">
- <match>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</match>
- </context>
-
- <!-- extra portage commands -->
- <context id="portcmds" style-ref="command">
- <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
- </context>
-
- <context id="built-in-command">
- <include> <!-- do not include "sh:built-in-command" as it is replaced down there - which would lead to an endless loop -->
- <context ref="sh:built-in-command-1" />
- <context ref="sh:built-in-command-2" />
- <context ref="portcmds" />
- </include>
- </context>
-
- <!-- gentoo is just a shell with the replacements -->
- <replace id="sh:built-in-command" ref="built-in-command" />
- <replace id="sh:backtick-subshell" ref="subprogram-2" />
- <context id="gentoo">
- <include>
- <context ref="subprogram"/>
- <context ref="sh:sh"/>
- </include>
- </context>
- </definitions>
-</language>
diff --git a/x11-libs/gtksourceview/gtksourceview-9999.ebuild b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
deleted file mode 100644
index 20ad3b5a..00000000
--- a/x11-libs/gtksourceview/gtksourceview-9999.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-VALA_MIN_API_VERSION="0.24"
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 vala virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="A text widget implementing syntax highlighting and other features"
-HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="3.0/3"
-
-IUSE="glade +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-fi
-
-# Note: has native OSX support, prefix teams, attack!
-RDEPEND="
- >=dev-libs/glib-2.47:2
- >=dev-libs/libxml2-2.6:2
- >=x11-libs/gtk+-3.19.6:3[introspection?]
- glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-1.42:= )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.24
- >=sys-devel/gettext-0.19.4
- dev-util/itstool
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.18 )"
-fi
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-deprecations \
- --enable-providers \
- $(use_enable glade glade-catalog) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_test() {
- Xemake check
-}
-
-src_install() {
- DOCS="AUTHORS HACKING MAINTAINERS NEWS README"
- gnome2_src_install
-
- insinto /usr/share/${PN}-3.0/language-specs
- doins "${FILESDIR}"/2.0/gentoo.lang
-}
diff --git a/x11-libs/gtksourceview/metadata.xml b/x11-libs/gtksourceview/metadata.xml
deleted file mode 100644
index 7bcd75b4..00000000
--- a/x11-libs/gtksourceview/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<use>
- <flag name="glade">Install a glade catalog file</flag>
-</use>
-</pkgmetadata>