summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--g_common/g_common.py7
-rw-r--r--g_common/settings.py2
2 files changed, 4 insertions, 5 deletions
diff --git a/g_common/g_common.py b/g_common/g_common.py
index 648daa4..1d942e5 100644
--- a/g_common/g_common.py
+++ b/g_common/g_common.py
@@ -170,11 +170,8 @@ def main():
return action_package(repo_location,package_name)
elif action=='usage' or action=='help':
return usage()
- elif action in pms_phases:
- #todo
- raise NotImplementedError
- elif action in actions_wanted:
- raise NotImplementedError
+ elif action in settings.PMS_PHASES:
+ return exec_phase(repo_location,action)
else:
return usage()
diff --git a/g_common/settings.py b/g_common/settings.py
index 5163c2f..1766a93 100644
--- a/g_common/settings.py
+++ b/g_common/settings.py
@@ -1,3 +1,5 @@
+PMS_PHASES=['pkg_pretend','pkg_setup','src_unpack','src_prepare','src_configure','src_compile',
+ 'src_test','src_install','pkg_preinst','pkg_postinst','pkg_prerm','pkg_postrm','pkg_config','pkg_info','pkg_nofetch']
GLOBAL_CONF_DIR='/usr/share/g-common/'
DRIVER_DIR='drivers/'
COMMON_EBUILD_FILE=GLOBAL_CONF_DIR+'common.ebuild'