aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2010-02-07 16:01:33 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2010-02-07 16:01:33 +0000
commit3b8ebef048788efca84844ff1ce5854b3fc2fbe0 (patch)
treea73e60b65001c1d68834f453285be9e4a0a4126a /media-libs
parentRemove old keywords and the overlay version of gst-plugins-good, (diff)
downloadembedded-cross-3b8ebef048788efca84844ff1ce5854b3fc2fbe0.tar.gz
embedded-cross-3b8ebef048788efca84844ff1ce5854b3fc2fbe0.tar.bz2
embedded-cross-3b8ebef048788efca84844ff1ce5854b3fc2fbe0.zip
Fix the pkgconfig file for the new stable version of alsa-lib.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/Manifest2
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.21a.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index a7a3749..b4b536c 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,4 +1,6 @@
AUX alsa-lib-exec_prefix-fix.patch 513 RMD160 cf01afba1e888b45413b2343fe4c5a8e60dc4735 SHA1 52575a14f3b6cc65583a6a9d481c38cfa8f74330 SHA256 e426ef6cb77dc59c5b4d915dc68a7ed6a4ea1117e81d6ddfd0461784dbc238d8
DIST alsa-lib-1.0.20.tar.bz2 794728 RMD160 8e0b48367abdd9d5746d2dc537014b1449e65e05 SHA1 0e6acce4301a4b3924e268a78e8c979a55cc8f88 SHA256 15f8d0eef1da10c62136107e7b585bc8beb9c9e9b7ad177654097f8c15e57a63
+DIST alsa-lib-1.0.21a.tar.bz2 808475 RMD160 38e615c25a93f4529f06e079584d379439ed9600 SHA1 49032964d22404455f3173629f271324bd8af211 SHA256 a6ce09afadc5428b09667cef32f7eba4ce0ea45aca27819edbe188e076d70074
EBUILD alsa-lib-1.0.20-r1.ebuild 2860 RMD160 b4e4f6c588522e508cbb0b6e43275afca3882259 SHA1 c76e44ea40521a90b33ec9e1a3554757a7b06ef4 SHA256 98e7aa50780eda278330ba707f1ed5b1a7cbdc340d6fc73316f32be74e14585f
EBUILD alsa-lib-1.0.20.ebuild 2986 RMD160 0f6a769735830ea873de75fd05a3771f60c51d47 SHA1 8f8ca74c27bb0b8b41ef53b9201733111bc7ead2 SHA256 cb46a52ff574b55aaa6dfc323262668159a397f0efe329624f471f008dd39975
+EBUILD alsa-lib-1.0.21a.ebuild 2577 RMD160 6ccc5bc897ca5b14790950cdb066f927e11fda37 SHA1 e93cca745a724a1d06e2df607254c16590d4dbb3 SHA256 0e0ae7d50e6ad44d15dc5d31dbd49bb4694ab84ab34fc5c4e82b127ae8988158
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.21a.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.21a.ebuild
new file mode 100644
index 0000000..99e1d43
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.21a.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.21a.ebuild,v 1.7 2010/02/06 18:12:23 tcunha Exp $
+
+inherit autotools eutils libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sh sparc x86"
+IUSE="doc debug alisp python"
+
+RDEPEND="python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ >=media-sound/alsa-headers-${PV%[[:lower:]]}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file
+null empty share meter mmap_emul hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+pkg_setup() {
+ if [ -z "${ALSA_PCM_PLUGINS}" ] ; then
+ ewarn "You haven't selected _any_ PCM plugins. Either you set it to something like the default"
+ ewarn "(which is being set in the profile UNLESS you unset them) or alsa based applications"
+ ewarn "are going to *misbehave* !"
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix the exec_prefix later used in the .pc file.
+ epatch "${FILESDIR}/alsa-lib-exec_prefix-fix.patch"
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable python) \
+ --with-pcm-plugins="${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO || die
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ elog "Please try in-kernel ALSA drivers instead of the alsa-drivers ebuild."
+ elog "If alsa-drivers works for you where a *recent* kernel does not, we want "
+ elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
+ elog "However, if you notice no sound output or instability, please try to "
+ elog "upgrade your kernel to a newer version first."
+}