aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-05-21 11:20:10 -0400
committerAnthony G. Basile <blueness@gentoo.org>2013-05-21 11:22:20 -0400
commit6251f49dbc8bfaba99c56b666453bb71521c95d2 (patch)
tree6f83563e0896199568e8e063d3e704e3601c6fe2
parentChangeLog: updated (diff)
downloadelfix-6251f49dbc8bfaba99c56b666453bb71521c95d2.tar.gz
elfix-6251f49dbc8bfaba99c56b666453bb71521c95d2.tar.bz2
elfix-6251f49dbc8bfaba99c56b666453bb71521c95d2.zip
Rename scripts/pax-mark -> scripts/paxmark.sh to avoid name collision with the eclass
-rw-r--r--ChangeLog4
-rw-r--r--scripts/Makefile.am2
-rwxr-xr-xscripts/paxmark.sh (renamed from scripts/pax-mark)4
3 files changed, 5 insertions, 5 deletions
diff --git a/ChangeLog b/ChangeLog
index 03ee71e..c6b049f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -5,8 +5,8 @@
elfutils from libelf. The former will not build on uclibc, but the laster
does not provide ELF_C_RDWR_MMAP.
* Clean up the tests so they work for all combinations of --{en,dis}able-{pt,xt}pax
- * Add a bash utility which does pax-marking like the eclass. This is for
- build systems that do pax-marking during the build.
+ * Add a bash utility, paxmark.sh, which does PaX marking like the eclass. This is for
+ build systems that do PaX marking during the build.
2012-12-28
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 5cef3e1..e5e5291 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,4 +1,4 @@
ACLOCAL_AMFLAGS = -I m4
-dist_sbin_SCRIPTS = migrate-pax pax-mark pypaxctl revdep-pax
+dist_sbin_SCRIPTS = migrate-pax paxmark.sh pypaxctl revdep-pax
EXTRA_DIST = paxmodule.c setup.py
diff --git a/scripts/pax-mark b/scripts/paxmark.sh
index c8fc7ed..02f966e 100755
--- a/scripts/pax-mark
+++ b/scripts/paxmark.sh
@@ -5,7 +5,7 @@ has() {
return 1
}
-pax-mark() {
+paxmarksh() {
local f # loop over paxables
local flags # pax flags
@@ -108,4 +108,4 @@ pax-mark() {
}
PAX_MARKINGS=${PAX_MARKINGS:="PT XT"}
-pax-mark "$@"
+paxmarksh "$@"