aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-10-08 14:12:56 -0400
committerAnthony G. Basile <blueness@gentoo.org>2011-10-08 14:53:27 -0400
commitc58aba802efc59d250f0585da3913908aa9070d8 (patch)
tree27c7b6dc5fe4d5ff338f48e8536b6608d245d8a5
parentscripts/revdep-pax: completed four command line options (diff)
downloadelfix-c58aba802efc59d250f0585da3913908aa9070d8.tar.gz
elfix-c58aba802efc59d250f0585da3913908aa9070d8.tar.bz2
elfix-c58aba802efc59d250f0585da3913908aa9070d8.zip
{scripts,src}/Makefile.am: install all utilities into /sbin
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac1
-rw-r--r--scripts/Makefile.am1
-rw-r--r--src/Makefile.am2
4 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fbec9a2..f092f0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,4 +4,4 @@ endif
if POC
SUBDIRS_POC = poc
endif
-SUBDIRS = src doc $(SUBDIRS_TESTS) $(SUBDIRS_POC)
+SUBDIRS = src scripts doc $(SUBDIRS_TESTS) $(SUBDIRS_POC)
diff --git a/configure.ac b/configure.ac
index ed6cd70..da3492c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,7 @@ AC_FUNC_ERROR_AT_LINE
AC_CONFIG_FILES([Makefile
src/Makefile
+ scripts/Makefile
doc/Makefile
poc/Makefile
tests/Makefile])
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
new file mode 100644
index 0000000..9faaeac
--- /dev/null
+++ b/scripts/Makefile.am
@@ -0,0 +1 @@
+sbin_SCRIPTS = revdep-pax
diff --git a/src/Makefile.am b/src/Makefile.am
index 8e4709c..cc46fe2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-bin_PROGRAMS = fix-gnustack paxctl-ng
+sbin_PROGRAMS = fix-gnustack paxctl-ng
fix_gnustack_SOURCES = fix-gnustack.c
fix_gnustack_LDADD = -lelf
paxctl_ng_SOURCES = paxctl-ng.c