summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-03-30 10:59:39 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-04-01 00:04:14 +0200
commit5ff1d6955496b3cf9a35042c9ac35db43bc336b1 (patch)
tree6d470f7eb448f59f53e8df1010aec9dad8ce1f72 /Makefile.in
parentImport Ghostscript 9.53.1 (diff)
downloadghostscript-gpl-patches-5ff1d6955496b3cf9a35042c9ac35db43bc336b1.tar.gz
ghostscript-gpl-patches-5ff1d6955496b3cf9a35042c9ac35db43bc336b1.tar.bz2
ghostscript-gpl-patches-5ff1d6955496b3cf9a35042c9ac35db43bc336b1.zip
Import Ghostscript 9.54ghostscript-9.54
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in43
1 files changed, 16 insertions, 27 deletions
diff --git a/Makefile.in b/Makefile.in
index 8fc446d6..5a647990 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1,4 +1,4 @@
-# Copyright (C) 2001-2020 Artifex Software, Inc.
+# Copyright (C) 2001-2021 Artifex Software, Inc.
# All Rights Reserved.
#
# This software is provided AS-IS with no warranty, either express or
@@ -117,6 +117,11 @@ COMPILE_INITS=@COMPILE_INITS@
GS_LIB_DEFAULT=$(gsdatadir)/Resource/Init:$(gsdatadir)/lib:$(gsdatadir)/Resource/Font:$(gsdir)/fonts:@fontpath@
+# Define the default search path for Tesseract. Separate multiple directories
+# with a :.
+
+TESSDATA=@tessdata@
+
# Define the default directory for cached data files
# this must be a single path.
@@ -223,6 +228,9 @@ CAL_SSE4_2_CFLAGS=@CAL_SSE4_2_CFLAGS@
CAL_AVX2_CFLAGS=@CAL_AVX2_CFLAGS@
CAL_NEON_CFLAGS=@CAL_NEON_CFLAGS@
+# Location of extract library (can be empty).
+EXTRACT_DIR=@EXTRACT_DIR@
+
# Define whether to compile in the FreeType library, and if so, where
# the source tree is location. Otherwise, what library name to use
# in linking to a shared implementation.
@@ -232,6 +240,7 @@ SHARE_FT=@SHARE_FT@
FTSRCDIR=@FTSRCDIR@
FT_CFLAGS=@FT_CFLAGS@ -DSHARE_FT=@SHARE_FT@
FT_LIBS=@FT_LIBS@
+FT_LIB_PATH=@FT_LIB_PATH@
FT_CONFIG_SYSTEM_ZLIB=@FT_SYS_ZLIB@
# Define whether to compile in UFST.
@@ -304,15 +313,6 @@ SHARE_JBIG2=@SHARE_JBIG2@
JBIG2SRCDIR=@JBIG2DIR@
JBIG2_CFLAGS=@JBIG2_AUTOCONF_CFLAGS@
-# uncomment the following three lines and one of the last two to
-# compile in the Luratech ldf_jb2 codec
-#JBIG2_LIB=luratech
-#SHARE_JBIG2=0
-#JBIG2SRCDIR=ldf_jb2
-#JBIG2_CFLAGS=-DUSE_LDF_JB2 -DLINUX
-#JBIG2_CFLAGS=-DUSE_LDF_JB2 -DMAC -DMAC_OS_X_BUILD
-
-
# Choose the library to use for (JPXDecode support)
# whether to link to an external build or compile in from source
# and source location and configuration flags for compiling in
@@ -321,20 +321,6 @@ SHARE_JPX=@SHARE_JPX@
JPXSRCDIR=@JPXDIR@
JPX_CFLAGS=-DSHARE_JPX=$(SHARE_JPX) @JPX_AUTOCONF_CFLAGS@ @JPX_SSE_CFLAGS@
-# uncomment the following three lines and one of the last two to
-# compile in the Luratech lwf_jp2 codec
-#JPX_LIB=luratech
-#SHARE_JPX=0
-#JPXSRCDIR=lwf_jp2
-#JPX_CFLAGS=-DUSE_LWF_JP2 -DLINUX
-#JPX_CFLAGS=-DUSE_LWF_JP2 -DMAC -DMAC_OS_X_BUILD
-
-# Uncomment the following 4 lines to to compile in OpenJPEG codec
-#JPX_LIB=openjpeg
-#SHARE_JPX=0
-#JPXSRCDIR=openjpeg
-#JPX_CFLAGS=-DUSE_OPENJPEG_JP2 -DOPJ_STATIC
-
# options for lcms color management library
SHARE_LCMS=@SHARELCMS@
LCMS2SRCDIR=@LCMS2DIR@
@@ -729,6 +715,8 @@ TESSSSE41=@TESS_SSE4_1@
TESSNEON=@TESS_NEON@
TESSCXXFLAGS=@TESS_CXXFLAGS@
TESSERACTDIR=@TESSERACTDIR@
+# Since C++ is only used for tesseract, set the compiler here
+CXX=@CXX@
# ---------------- End of platform-specific section ---------------- #
@@ -750,18 +738,17 @@ include @PXL_MAK@ # pxl.mak
include @XPS_MAK@ # xps.mak
+include $(GLSRCDIR)/jpeg.mak
+
include @GPDL_MAK@ # gpdl.mak
include $(GLSRCDIR)/freetype.mak
include @FAPIUFST_MAK@
-include $(GLSRCDIR)/jpeg.mak
# zlib.mak must precede png.mak
include $(GLSRCDIR)/zlib.mak
include $(GLSRCDIR)/png.mak
include $(GLSRCDIR)/tiff.mak
include $(GLSRCDIR)/jbig2.mak
-include $(GLSRCDIR)/ldf_jb2.mak
-include $(GLSRCDIR)/lwf_jp2.mak
include $(GLSRCDIR)/openjpeg.mak
include $(GLSRCDIR)/cal.mak
@LEPTONICAINCLUDE@
@@ -771,6 +758,8 @@ include $(GLSRCDIR)/ocr.mak
include $(GLSRCDIR)/jpegxr.mak
include $(GLSRCDIR)/expat.mak
+include $(DEVSRCDIR)/extract.mak
+
include $(GLSRCDIR)/$(WHICH_CMS).mak
include $(GLSRCDIR)/ijs.mak
@LCUPSINCLUDE@