aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2014-05-16 12:14:35 -0700
committerBrian Dolbec <dolsen@gentoo.org>2014-05-16 12:14:35 -0700
commit354e66075d711f757c94ae8a27a5e9d28365456c (patch)
tree295f0aecdee73591f193b97eea7f17990492b4cd
parentmodules/catalyst_support.py: Update snakeoil import path change (diff)
downloadcatalyst-354e66075d711f757c94ae8a27a5e9d28365456c.tar.gz
catalyst-354e66075d711f757c94ae8a27a5e9d28365456c.tar.bz2
catalyst-354e66075d711f757c94ae8a27a5e9d28365456c.zip
kmerge.sh: fix lack of exported clst_make_conf variable
This patch fixes commit: 63e36535a830364948a3ee258e7ab1e13905d6da Fix merging kernel without kerncache enabled. Guy Martin <gmsoft@gentoo.org> (Wed Feb 5 02:39:59 2014) Commited by me, cherry-picked from the 3.0 branch. Also replace the hard-coded sed make.conf path.
-rwxr-xr-xtargets/support/kmerge.sh6
1 files changed, 4 insertions, 2 deletions
diff --git a/targets/support/kmerge.sh b/targets/support/kmerge.sh
index c1b6a359..9786fdde 100755
--- a/targets/support/kmerge.sh
+++ b/targets/support/kmerge.sh
@@ -263,16 +263,18 @@ else
fi
fi
+# temp define this until make.conf path is exported to the bash environment
+export clst_make_conf=/etc/portage/make.conf
# Update USE flag in make.conf
-[ -e ${clst_make_conf} ] && \
+[[ -e ${clst_make_conf} ]] && \
echo "USE=\"\${USE} ${clst_kernel_use} build\"" >> ${clst_make_conf}
make_destpath
build_kernel
-sed -i "/USE=\"\${USE} ${clst_kernel_use} \"/d" /etc/portage/make.conf
+sed -i "/USE=\"\${USE} ${clst_kernel_use} \"/d" ${clst_make_conf}
# grep out the kernel version so that we can do our modules magic
VER=`grep ^VERSION\ \= /usr/src/linux/Makefile | awk '{ print $3 };'`
PAT=`grep ^PATCHLEVEL\ \= /usr/src/linux/Makefile | awk '{ print $3 };'`