diff options
author | Richard Henderson <rth@redhat.com> | 2004-01-16 05:59:42 +0000 |
---|---|---|
committer | Richard Henderson <rth@redhat.com> | 2004-01-16 05:59:42 +0000 |
commit | 60cd0f0ab63d20939a2527c924dc6b37121414b8 (patch) | |
tree | 79e64f991b98fd648923258dc7e24913e677ff72 | |
parent | * sysdeps/alpha/tls.h (tcbhead_t): Add private. (TLS_INIT_TCB... (diff) | |
download | glibc-60cd0f0ab63d20939a2527c924dc6b37121414b8.tar.gz glibc-60cd0f0ab63d20939a2527c924dc6b37121414b8.tar.bz2 glibc-60cd0f0ab63d20939a2527c924dc6b37121414b8.zip |
* sysdeps/alpha/dl-machine.h (RTLD_START): Use _dl_argv_internal.
* sysdeps/alpha/dl-machine.h (RTLD_START): Use _dl_argv_internal.
2004-01-15 Richard Henderson <rth@redhat.com>
-rw-r--r-- | ChangeLog | 4 | ||||
-rw-r--r-- | sysdeps/alpha/dl-machine.h | 7 |
2 files changed, 8 insertions, 3 deletions
@@ -1,5 +1,9 @@ 2004-01-15 Richard Henderson <rth@redhat.com> + * sysdeps/alpha/dl-machine.h (RTLD_START): Use _dl_argv_internal. + +2004-01-15 Richard Henderson <rth@redhat.com> + * sysdeps/unix/sysv/linux/alpha/Makefile [stdlib]: Process ucontext-offsets.sym. * sysdeps/unix/sysv/linux/alpha/getcontext.S: New file. diff --git a/sysdeps/alpha/dl-machine.h b/sysdeps/alpha/dl-machine.h index 6680abf379..3616faedbf 100644 --- a/sysdeps/alpha/dl-machine.h +++ b/sysdeps/alpha/dl-machine.h @@ -1,5 +1,5 @@ /* Machine-dependent ELF dynamic relocation inline functions. Alpha version. - Copyright (C) 1996-2002, 2003 Free Software Foundation, Inc. + Copyright (C) 1996-2002, 2003, 2004 Free Software Foundation, Inc. This file is part of the GNU C Library. Contributed by Richard Henderson <rth@tamu.edu>. @@ -348,15 +348,16 @@ $fixup_stack: \n\ /* Adjust the stack pointer to skip _dl_skip_args words.\n\ This involves copying everything down, since the \n\ stack pointer must always be 16-byte aligned. */ \n\ + ldah $7, _dl_argv_internal($gp) !gprelhigh \n\ ldq $2, 0($sp) \n\ - ldq $5, _dl_argv \n\ + ldq $5, _dl_argv_internal($7) !gprellow \n\ subq $31, $1, $6 \n\ subq $2, $1, $2 \n\ s8addq $6, $5, $5 \n\ mov $sp, $4 \n\ s8addq $1, $sp, $3 \n\ stq $2, 0($sp) \n\ - stq $5, _dl_argv \n\ + stq $5, _dl_argv_internal($7) !gprellow \n\ /* Copy down argv. */ \n\ 0: ldq $5, 8($3) \n\ addq $4, 8, $4 \n\ |