aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2008-07-17 15:59:24 +0000
committerBenjamin Peterson <benjamin@python.org>2008-07-17 15:59:24 +0000
commit4347c44f1834887602402b7eec0e82214bd6bd1d (patch)
tree2025995da92aa949523677c29710e858202409ea /configure.in
parenttry to fix test_threading on the Windows bot (diff)
downloadcpython-4347c44f1834887602402b7eec0e82214bd6bd1d.tar.gz
cpython-4347c44f1834887602402b7eec0e82214bd6bd1d.tar.bz2
cpython-4347c44f1834887602402b7eec0e82214bd6bd1d.zip
#3381 fix framework builds on 10.4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 28 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 7941f2dd742..67d7f969a11 100644
--- a/configure.in
+++ b/configure.in
@@ -903,6 +903,8 @@ yes)
Darwin*)
# -Wno-long-double, -no-cpp-precomp, and -mno-fused-madd
# used to be here, but non-Apple gcc doesn't accept them.
+
+
if test "${enable_universalsdk}"; then
UNIVERSAL_ARCH_FLAGS=""
if test "$UNIVERSAL_ARCHS" = "32-bit" ; then
@@ -923,9 +925,34 @@ yes)
BASECFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${BASECFLAGS}"
- CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ tgt=`sw_vers -productVersion | sed 's/\(10\.[0-9]*\).*/\1/'`
+ if test "${UNIVERSALSDK}" != "/" -a "${tgt}" '>' '10.4' ; then
+ CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ fi
fi
+ # Calculate the right deployment target for this build.
+ #
+ cur_target=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
+ if test ${cur_target} '>' 10.2; then
+ cur_target=10.3
+ fi
+ if test "${UNIVERSAL_ARCHS}" = "all"; then
+ # Ensure that the default platform for a 4-way
+ # universal build is OSX 10.5, that's the first
+ # OS release where 4-way builds make sense.
+ cur_target='10.5'
+ fi
+ CONFIGURE_MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET-${cur_target}}
+
+ # Make sure that MACOSX_DEPLOYMENT_TARGET is set in the
+ # environment with a value that is the same as what we'll use
+ # in the Makefile to ensure that we'll get the same compiler
+ # environment during configure and build time.
+ MACOSX_DEPLOYMENT_TARGET="$CONFIGURE_MACOSX_DEPLOYMENT_TARGET"
+ export MACOSX_DEPLOYMENT_TARGET
+ EXPORT_MACOSX_DEPLOYMENT_TARGET=''
+
;;
OSF*)
BASECFLAGS="$BASECFLAGS -mieee"
@@ -1624,26 +1651,7 @@ then
Darwin/*)
# Use -undefined dynamic_lookup whenever possible (10.3 and later).
# This allows an extension to be used in any Python
- cur_target=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
- if test ${cur_target} '>' 10.2; then
- cur_target=10.3
- fi
- if test "${UNIVERSAL_ARCHS}" = "all"; then
- # Ensure that the default platform for a 4-way
- # universal build is OSX 10.5, that's the first
- # OS release where 4-way builds make sense.
- cur_target='10.5'
- fi
- CONFIGURE_MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET-${cur_target}}
-
- # Make sure that MACOSX_DEPLOYMENT_TARGET is set in the
- # environment with a value that is the same as what we'll use
- # in the Makefile to ensure that we'll get the same compiler
- # environment during configure and build time.
- MACOSX_DEPLOYMENT_TARGET="$CONFIGURE_MACOSX_DEPLOYMENT_TARGET"
- export MACOSX_DEPLOYMENT_TARGET
- EXPORT_MACOSX_DEPLOYMENT_TARGET=''
if test ${MACOSX_DEPLOYMENT_TARGET} '>' 10.2
then
if test "${enable_universalsdk}"; then