aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Protzenko <protz@microsoft.com>2023-02-22 13:18:43 -0800
committerGitHub <noreply@github.com>2023-02-22 13:18:43 -0800
commitfcadc7e405141847ab10daf5cff16be880083a24 (patch)
tree404c9bc7b90e95882765731171033632aa6c9b80 /Makefile.pre.in
parentGH-101777: `queue.rst`: use 2 spaces after a period to be consistent. (#102143) (diff)
downloadcpython-fcadc7e405141847ab10daf5cff16be880083a24.tar.gz
cpython-fcadc7e405141847ab10daf5cff16be880083a24.tar.bz2
cpython-fcadc7e405141847ab10daf5cff16be880083a24.zip
gh-99108: Import MD5 and SHA1 from HACL* (#102089)
Replaces our fallback non-OpenSSL MD5 and SHA1 implementations with those from HACL* as we've already done with SHA2.
Diffstat (limited to 'Makefile.pre.in')
-rw-r--r--Makefile.pre.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/Makefile.pre.in b/Makefile.pre.in
index b28c6067a53..b12a1bc060a 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -578,17 +578,21 @@ LIBEXPAT_HEADERS= \
LIBHACL_SHA2_OBJS= \
Modules/_hacl/Hacl_Streaming_SHA2.o
-LIBHACL_SHA2_HEADERS= \
- Modules/_hacl/Hacl_Streaming_SHA2.h \
+LIBHACL_HEADERS= \
Modules/_hacl/include/krml/FStar_UInt128_Verified.h \
Modules/_hacl/include/krml/FStar_UInt_8_16_32_64.h \
Modules/_hacl/include/krml/fstar_uint128_struct_endianness.h \
Modules/_hacl/include/krml/internal/target.h \
Modules/_hacl/include/krml/lowstar_endianness.h \
Modules/_hacl/include/krml/types.h \
- Modules/_hacl/internal/Hacl_SHA2_Generic.h \
+ Modules/_hacl/Hacl_Streaming_Types.h \
Modules/_hacl/python_hacl_namespaces.h
+LIBHACL_SHA2_HEADERS= \
+ Modules/_hacl/Hacl_Streaming_SHA2.h \
+ Modules/_hacl/internal/Hacl_SHA2_Generic.h \
+ $(LIBHACL_HEADERS)
+
#########################################################################
# Rules
@@ -2635,8 +2639,8 @@ MODULE__DECIMAL_DEPS=$(srcdir)/Modules/_decimal/docstrings.h @LIBMPDEC_INTERNAL@
MODULE__ELEMENTTREE_DEPS=$(srcdir)/Modules/pyexpat.c @LIBEXPAT_INTERNAL@
MODULE__HASHLIB_DEPS=$(srcdir)/Modules/hashlib.h
MODULE__IO_DEPS=$(srcdir)/Modules/_io/_iomodule.h
-MODULE__MD5_DEPS=$(srcdir)/Modules/hashlib.h
-MODULE__SHA1_DEPS=$(srcdir)/Modules/hashlib.h
+MODULE__MD5_DEPS=$(srcdir)/Modules/hashlib.h $(LIBHACL_HEADERS) Modules/_hacl/Hacl_Hash_MD5.h Modules/_hacl/Hacl_Hash_MD5.c
+MODULE__SHA1_DEPS=$(srcdir)/Modules/hashlib.h $(LIBHACL_HEADERS) Modules/_hacl/Hacl_Hash_SHA1.h Modules/_hacl/Hacl_Hash_SHA1.c
MODULE__SHA2_DEPS=$(srcdir)/Modules/hashlib.h $(LIBHACL_SHA2_HEADERS) $(LIBHACL_SHA2_A)
MODULE__SHA3_DEPS=$(srcdir)/Modules/_sha3/sha3.c $(srcdir)/Modules/_sha3/sha3.h $(srcdir)/Modules/hashlib.h
MODULE__SOCKET_DEPS=$(srcdir)/Modules/socketmodule.h $(srcdir)/Modules/addrinfo.h $(srcdir)/Modules/getaddrinfo.c $(srcdir)/Modules/getnameinfo.c