aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-10-11 13:50:03 -0400
committerMichał Górny <mgorny@gentoo.org>2024-09-07 08:33:46 +0200
commitfc855a3d790ff08dfbd33f67e58936c4f96205a6 (patch)
tree5fa3fc06e8deb847a04ba2dfee679bfbff9d3ee6
parentbpo-43998: Default to TLS 1.2 and increase cipher suite security (GH-25778) (diff)
downloadcpython-fc855a3d790ff08dfbd33f67e58936c4f96205a6.tar.gz
cpython-fc855a3d790ff08dfbd33f67e58936c4f96205a6.tar.bz2
cpython-fc855a3d790ff08dfbd33f67e58936c4f96205a6.zip
bpo-45433: Do not link libpython against libcrypt
Save/restore LIBS when calling AC_SEARCH_LIBS(..., crypt). This avoid linking libpython with libcrypt.
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a760b508986..38594c3a919 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4043,6 +4043,8 @@ AC_CHECK_FUNCS(setpgrp,
# We search for both crypt and crypt_r as one or the other may be defined
# This gets us our -lcrypt in LIBS when required on the target platform.
+# Save/restore LIBS to avoid linking libpython with libcrypt.
+LIBS_SAVE=$LIBS
AC_SEARCH_LIBS(crypt, crypt)
AC_SEARCH_LIBS(crypt_r, crypt)
@@ -4057,6 +4059,7 @@ char *r = crypt_r("", "", &d);
[AC_DEFINE(HAVE_CRYPT_R, 1, [Define if you have the crypt_r() function.])],
[])
)
+LIBS=$LIBS_SAVE
AC_CHECK_FUNCS(clock_gettime, [], [
AC_CHECK_LIB(rt, clock_gettime, [