aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Biesinger <cbiesinger@google.com>2019-10-31 14:41:19 -0500
committerChristian Biesinger <cbiesinger@google.com>2019-10-31 15:14:14 -0500
commitb231e86ac9608056ea837e24d42a878927f5787a (patch)
tree29b98002638e43c04d5a02a23501ea717932c750 /gdb/ChangeLog
parent[ARM] Store exception handling information per-bfd instead of per-objfile (diff)
downloadbinutils-gdb-b231e86ac9608056ea837e24d42a878927f5787a.tar.gz
binutils-gdb-b231e86ac9608056ea837e24d42a878927f5787a.tar.bz2
binutils-gdb-b231e86ac9608056ea837e24d42a878927f5787a.zip
Use strerror_r in safe_strerror if available
Also stores the result in a thread-local static variable and changes the return value to a const char*. This is already important because Guile creates threads and Python can create threads, but with the patch series here: https://gnutoolchain-gerrit.osci.io/r/c/binutils-gdb/+/176 GDB itself will create threads, too. gdb/ChangeLog: 2019-10-31 Christian Biesinger <cbiesinger@google.com> * configure: Regenerate. * configure.ac: Check for strerror_r. * gdbsupport/common-utils.h (safe_strerror): Change return value to const char * and document that this function is now threadsafe. * gdbsupport/posix-strerror.c (safe_strerror): Make buf thread_local and call strerror_r, if available. * utils.c (perror_string): Update. (print_sys_errmsg): Update. Change-Id: I81048fbaf148035c221c528727f7efe58ba528eb
Diffstat (limited to 'gdb/ChangeLog')
-rw-r--r--gdb/ChangeLog11
1 files changed, 11 insertions, 0 deletions
diff --git a/gdb/ChangeLog b/gdb/ChangeLog
index 7abe20ee59c..b7a7d98c8a2 100644
--- a/gdb/ChangeLog
+++ b/gdb/ChangeLog
@@ -1,3 +1,14 @@
+2019-10-31 Christian Biesinger <cbiesinger@google.com>
+
+ * configure: Regenerate.
+ * configure.ac: Check for strerror_r.
+ * gdbsupport/common-utils.h (safe_strerror): Change return value
+ to const char * and document that this function is now threadsafe.
+ * gdbsupport/posix-strerror.c (safe_strerror): Make buf
+ thread_local and call strerror_r, if available.
+ * utils.c (perror_string): Update.
+ (print_sys_errmsg): Update.
+
2019-10-31 Luis Machado <luis.machado@linaro.org>
* arm-tdep.c (arm_exidx_data_key): Use bfd_key instead of