aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-07 00:15:53 -0500
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-02-07 02:05:11 +0200
commit2f48b5ed58bade1630590c45e82409bc57ae9970 (patch)
tree0a731d66e5f6a4f916dce80fecf0f277296d0cd5
parentGentoo: gold/ld: add support for poisoned system directories (diff)
downloadbinutils-gdb-2f48b5ed58bade1630590c45e82409bc57ae9970.tar.gz
binutils-gdb-2f48b5ed58bade1630590c45e82409bc57ae9970.tar.bz2
binutils-gdb-2f48b5ed58bade1630590c45e82409bc57ae9970.zip
Gentoo: libiberty: install PIC version of libiberty.a
This will install a PIC version of libiberty.a by overwriting the non-PIC version of libiberty.a while compiling. We do this because there is no shared version of libiberty for random apps to link against which means if someone wants to use this in a shared library or PIE, they're out of luck. It's arguable whether people should be able to use this in a shared lib, but usage in PIE should be fine. You could argue that this penalizes the non-PIE users, but the counter point is that people using this library in general are fairly low, and we'd rather have things work for all of them. (cherry picked from commit 112aff9ad3e2675556370c4281117a6df0a879d9)
-rw-r--r--libiberty/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/libiberty/Makefile.in b/libiberty/Makefile.in
index 895f701bcd0..baa12cfa6cf 100644
--- a/libiberty/Makefile.in
+++ b/libiberty/Makefile.in
@@ -257,6 +257,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
$(AR) $(AR_FLAGS) $(TARGETLIB) \
$(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
$(RANLIB) $(TARGETLIB); \
+ cp $(TARGETLIB) ../ ; \
cd ..; \
else true; fi; \
if [ x"$(NOASANFLAG)" != x ]; then \