aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-05 20:24:00 +0545
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-07-15 13:26:08 +0200
commit85df674f53ee5f3918c98523d7e20849b789291b (patch)
treee0e7bc10b9f798f610172253f6fc3512791fd5a7
parentGentoo: libiberty: install PIC version of libiberty.a (diff)
downloadbinutils-gdb-85df674f53ee5f3918c98523d7e20849b789291b.tar.gz
binutils-gdb-85df674f53ee5f3918c98523d7e20849b789291b.tar.bz2
binutils-gdb-85df674f53ee5f3918c98523d7e20849b789291b.zip
Gentoo: opcodes: link against libbfd.la for rpath deps
The reason opcodes doesn't link against libbfd.la is to workaround a libtool bug where it uses installed -L paths ahead of DESTDIR paths. The downside is that the library itself lacks rpath tags to find the right version of libbfd.so. Since Gentoo has patched the libtool bug for a while, we don't need the workaround. Use the .la file so we get the rpath tags. URL: https://bugs.gentoo.org/563934 (cherry picked from commit 662586237b0b00ee881e79b56f6234ff36e8bfe6)
-rwxr-xr-xopcodes/configure2
-rw-r--r--opcodes/configure.ac2
2 files changed, 2 insertions, 2 deletions
diff --git a/opcodes/configure b/opcodes/configure
index 2b6d7322cda..64638c63a8d 100755
--- a/opcodes/configure
+++ b/opcodes/configure
@@ -12849,7 +12849,7 @@ if test "$enable_shared" = "yes"; then
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"
diff --git a/opcodes/configure.ac b/opcodes/configure.ac
index d820dc9938a..cacb2f3439f 100644
--- a/opcodes/configure.ac
+++ b/opcodes/configure.ac
@@ -184,7 +184,7 @@ changequote([,])dnl
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"