summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2010-05-15 02:05:43 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2010-05-15 02:05:43 +0000
commitd2ad4548a7fa68b8208dd0739ed71603b80abab8 (patch)
tree34326a06e823794d6a9c3ded587037912bfdcc3c
parentadd Manifest (diff)
downloadje_fro-d2ad4548a7fa68b8208dd0739ed71603b80abab8.tar.gz
je_fro-d2ad4548a7fa68b8208dd0739ed71603b80abab8.tar.bz2
je_fro-d2ad4548a7fa68b8208dd0739ed71603b80abab8.zip
fix in my overlay for bug #316287
svn path=/; revision=298
-rw-r--r--app-office/abiword/Manifest3
-rw-r--r--app-office/abiword/abiword-2.8.4.ebuild166
-rw-r--r--app-office/abiword/files/abiword-2.8.4-collab.patch45
3 files changed, 214 insertions, 0 deletions
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
new file mode 100644
index 0000000..62fb130
--- /dev/null
+++ b/app-office/abiword/Manifest
@@ -0,0 +1,3 @@
+AUX abiword-2.8.4-collab.patch 1530 RMD160 07d7d9817b31fab3925570b890978701c83d1cbb SHA1 d6da7a01abbd16fbbbfd7ee616ad3d40b1e13322 SHA256 e4b94199710bfd61a34735108be6292864a36b82d35c9e4da2bc4554c77e070c
+DIST abiword-2.8.4.tar.gz 9133449 RMD160 e775a3b609860c982d104b1fac45e68e3ac026dc SHA1 bf5f0409f1d658d48d9fe2fe454fc4e553eb757c SHA256 14a4b4638a38bbff225e20e8e2dbc9d32166f40009caf7bd86cc48c4d8404eec
+EBUILD abiword-2.8.4.ebuild 4806 RMD160 95df064a6e8a63bdfce2167e280854c2d45e8d0a SHA1 99adf10c0dbeff4809681cf3a4d38f22933424ec SHA256 6c026bfa57ae6a1046a54c1fad2a4192cc2cc316d15d67e0914f79851e4f6740
diff --git a/app-office/abiword/abiword-2.8.4.ebuild b/app-office/abiword/abiword-2.8.4.ebuild
new file mode 100644
index 0000000..c22df30
--- /dev/null
+++ b/app-office/abiword/abiword-2.8.4.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.8.4.ebuild,v 1.1 2010/04/19 23:16:35 eva Exp $
+
+EAPI="3"
+
+inherit alternatives autotools gnome2 versionator
+
+MY_MAJORV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="collab cups gnome grammar latex libgda math ots openxml plugins readline spell wordperfect wmf thesaurus" # svg
+
+# libgsf raised to make sure it provides gio backend (ebuild)
+# not enabling telepathy backend for collab, it depends on libempathy-gtk which
+# has be removed from empathy-2.30 already
+RDEPEND="
+ >=app-text/wv-1.2
+ >=dev-libs/fribidi-0.10.4
+ >=dev-libs/glib-2.16
+ >=gnome-base/librsvg-2.16
+ >=gnome-extra/libgsf-1.14.15
+ >=media-libs/libpng-1.2
+ media-libs/jpeg:0
+ >=x11-libs/cairo-1.8[X]
+ >=x11-libs/gtk+-2.14[cups?]
+ gnome? (
+ >=gnome-extra/gucharmap-2
+ >=x11-libs/goffice-0.8:0.8 )
+ plugins? (
+ collab? (
+ dev-cpp/asio
+ >=dev-libs/boost-1.33.1
+ >=dev-libs/libxml2-2.4
+ >=net-libs/loudmouth-1
+ net-libs/libsoup:2.4
+ net-libs/gnutls )
+ grammar? ( >=dev-libs/link-grammar-4.2.1 )
+ latex? ( dev-libs/libxslt )
+ libgda? (
+ =gnome-extra/libgda-1*
+ =gnome-extra/libgnomedb-1* )
+ math? ( >=x11-libs/gtkmathview-0.7.5 )
+ openxml? ( dev-libs/boost )
+ ots? ( >=app-text/ots-0.5 )
+ readline? ( sys-libs/readline )
+ thesaurus? ( >=app-text/aiksaurus-1.2[gtk] )
+ wordperfect? (
+ >=app-text/libwpd-0.8
+ >=media-libs/libwpg-0.1 )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ )
+ spell? ( >=app-text/enchant-1.2 )
+ !<app-office/abiword-plugins-2.8"
+# svg? ( >=gnome-base/librsvg-2 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ # do not enable gnome-vfs
+ G2CONF="${G2CONF}
+ --enable-shave
+ --disable-static
+ --disable-maintainer-mode
+ --disable-default-plugins
+ --disable-builtin-plugins
+ --disable-collab-backend-telepathy
+ --enable-clipart
+ --enable-statusbar
+ --enable-templates
+ --with-gio
+ --without-gnomevfs
+ $(use_with gnome goffice)
+ $(use_enable cups print)
+ $(use_enable collab collab-backend-xmpp)
+ $(use_enable collab collab-backend-tcp)
+ $(use_enable collab collab-backend-service)
+ $(use_enable spell)"
+}
+
+gnome2_src_prepare() {
+ # workaround for #316287, patch from abisource #12701
+ patch -p1 < "${FILESDIR}/${P}-collab.patch"
+ patch plugin-configure.m4 < "${FILESDIR}/${P}-collab.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local plugins=""
+
+ if use plugins; then
+ # Plugins depending on libgsf
+ plugins="t602 docbook clarisworks wml kword hancom openwriter pdf
+ loadbindings mswrite garble pdb applix opendocument sdw xslfo"
+
+ # Plugins not depending on anything
+ plugins="${plugins} gimp bmp freetranslation iscii s5 babelfish opml eml
+ wikipedia gdict passepartout google presentation urldict hrtext mif"
+
+ # inter7eps: eps.h
+ # libtidy: gsf + tidy.h
+ # paint: windows only ?
+ use collab && plugins="${plugins} collab"
+ use gnome && plugins="${plugins} goffice"
+ use latex && plugins="${plugins} latex"
+ use libgda && plugins="${plugins} gda"
+ use math && plugins="${plugins} mathview"
+ use openxml && plugins="${plugins} openxml"
+ use ots && plugins="${plugins} ots"
+ # psion: >=psiconv-0.9.4
+ use readline && plugins="${plugins} command"
+ # plugin doesn't build
+ #use svg && plugins="${plugins} rsvg"
+ use thesaurus && plugins="${plugins} aiksaurus"
+ use wmf && plugins="${plugins} wmf"
+ # wordperfect: >=wpd-0.8 >=wps-0.1
+ use wordperfect && plugins="${plugins} wpg"
+ fi
+
+ gnome2_src_configure --enable-plugins="$(echo ${plugins})"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # install icon to pixmaps (bug #220097)
+ sed 's:icondir= $(datadir)/icons:icondir = $(datadir)/pixmaps:' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ # readme.txt will be installed using dodoc
+ sed '/readme\.txt\|abw/d' \
+ -i user/wp/Makefile.am user/wp/Makefile.in || die "sed 2 failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ sed "s:Exec=abiword:Exec=abiword-${MY_MAJORV}:" \
+ -i "${D}"/usr/share/applications/abiword.desktop || die "sed 3 failed"
+
+ mv "${D}/usr/bin/abiword" "${D}/usr/bin/AbiWord-${MY_MAJORV}"
+ dosym AbiWord-${MY_MAJORV} /usr/bin/abiword-${MY_MAJORV}
+
+ dodoc AUTHORS user/wp/readme.txt || die "dodoc failed"
+
+ # Not needed
+ find "${D}" -name "*.la" -delete || die "failed *.la removal"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ alternatives_auto_makesym "/usr/bin/abiword" "/usr/bin/abiword-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ alternatives_auto_makesym "/usr/bin/abiword" "/usr/bin/abiword-[0-9].[0-9]"
+}
diff --git a/app-office/abiword/files/abiword-2.8.4-collab.patch b/app-office/abiword/files/abiword-2.8.4-collab.patch
new file mode 100644
index 0000000..4321069
--- /dev/null
+++ b/app-office/abiword/files/abiword-2.8.4-collab.patch
@@ -0,0 +1,45 @@
+diff -ur a/plugins/collab/plugin.m4 b/plugins/collab/plugin.m4
+--- a/plugins/collab/plugin.m4 2010-04-14 23:50:17.000000000 +0200
++++ b/plugins/collab/plugin.m4 2010-04-20 03:29:37.000000000 +0200
+@@ -47,12 +47,14 @@
+ [AS_HELP_STRING([--enable-collab-backend-tcp], [TCP backend (default: auto)])],
+ [
+ enable_collab_backend_tcp=$enableval
+- AC_LANG_PUSH(C++)
+- AC_CHECK_HEADERS([asio.hpp], [],
+- [
+- AC_MSG_ERROR([collab plugin: asio is required for the collab plugin TCP backend, see http://think-async.com/])
+- ])
+- AC_LANG_POP
++ if test "$enable_collab_backend_tcp" != "no"; then
++ AC_LANG_PUSH(C++)
++ AC_CHECK_HEADERS([asio.hpp], [],
++ [
++ AC_MSG_ERROR([collab plugin: asio is required for the collab plugin TCP backend, see http://think-async.com/])
++ ])
++ AC_LANG_POP
++ fi
+ ], [
+ AC_LANG_PUSH(C++)
+ AC_CHECK_HEADERS([asio.hpp],
+@@ -82,12 +84,14 @@
+ [AS_HELP_STRING([--enable-collab-backend-service], [abicollab.net backend (default: auto)])],
+ [
+ enable_collab_backend_service=$enableval
+- AC_LANG_PUSH(C++)
+- AC_CHECK_HEADERS([asio.hpp], [],
+- [
+- AC_MSG_ERROR([collab plugin: asio is required for the the abicollab.net backend, see http://think-async.com/])
+- ])
+- AC_LANG_POP
++ if test "$enable_collab_backend_service" != "no"; then
++ AC_LANG_PUSH(C++)
++ AC_CHECK_HEADERS([asio.hpp], [],
++ [
++ AC_MSG_ERROR([collab plugin: asio is required for the the abicollab.net backend, see http://think-async.com/])
++ ])
++ AC_LANG_POP
++ fi
+ ], [
+ AC_LANG_PUSH(C++)
+ AC_CHECK_HEADERS([asio.hpp],