summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/uniloader/uniloader-21.04.1.ebuild')
-rw-r--r--app-metrics/uniloader/uniloader-21.04.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-metrics/uniloader/uniloader-21.04.1.ebuild b/app-metrics/uniloader/uniloader-21.04.1.ebuild
new file mode 100644
index 0000000..79df83d
--- /dev/null
+++ b/app-metrics/uniloader/uniloader-21.04.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# DISCLAIMER:
+# This ebuild does NOT follow the Gentoo QA Rules, instead it follows the upstream way to install and run the application
+
+EAPI=7
+
+DESCRIPTION="A go-based program that uploads data to a local or remote QueueMetrics"
+HOMEPAGE="https://www.queuemetrics-live.com/uniloader.jsp"
+LICENSE="all-rights-reserved"
+SRC_URI="https://downloads.loway.ch/qm/${P}.tar.gz"
+RESTRICT="mirror"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="acct-group/queuemetrics
+ acct-user/queuemetrics"
+
+src_install() {
+ dodir /opt/${PN}/bin
+ exeinto /opt/${PN}/bin
+ newexe bin/${PN}_amd64 ${PN}
+
+ keepdir /var/log/${PN}
+ fowners queuemetrics:queuemetrics /var/log/${PN}
+ fperms 0750 /var/log/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}