# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild,v 1.5 2007/04/06 04:51:06 nyhm Exp $

inherit games

MY_P="tr64gl-${PV/_/-}"
DESCRIPTION="An OpenGL graphics plugin for the mupen64 N64 emulator"
HOMEPAGE="http://deltaanime.ath.cx/~blight/n64/"
SRC_URI="mirror://gentoo/${MY_P}.so.gz"

LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
IUSE=""
RESTRICT="strip"

RDEPEND="media-libs/libsdl"

S=${WORKDIR}

src_install() {
	exeinto "$(games_get_libdir)"/mupen64/plugins
	doexe ${MY_P}.so || die "doexe failed"
	prepgamesdirs
}