From 891ae23cf72767941687a3bc88506f49b0fc5e17 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Sun, 23 Aug 2009 10:53:04 +0000
Subject: Version bump #231440 by Pacho Ramos, Robert A., Marcus D. Hanwell,
 and Paul Hartman. (Portage version: 2.2_rc38/cvs/Linux x86_64, RepoMan
 options: --force)

---
 app-emulation/crossover-office-pro-bin/ChangeLog   | 15 ++++++-
 .../crossover-office-pro-bin-7.0.2.ebuild          | 49 ++++++++++++++++++++++
 .../crossover-office-pro-bin-7.1.0.ebuild          | 49 ++++++++++++++++++++++
 .../crossover-office-pro-bin-8.0.0.ebuild          | 49 ++++++++++++++++++++++
 4 files changed, 160 insertions(+), 2 deletions(-)
 create mode 100644 app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.0.2.ebuild
 create mode 100644 app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.1.0.ebuild
 create mode 100644 app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-8.0.0.ebuild

(limited to 'app-emulation/crossover-office-pro-bin')

diff --git a/app-emulation/crossover-office-pro-bin/ChangeLog b/app-emulation/crossover-office-pro-bin/ChangeLog
index 4a18bbacba73..d5de2d08e699 100644
--- a/app-emulation/crossover-office-pro-bin/ChangeLog
+++ b/app-emulation/crossover-office-pro-bin/ChangeLog
@@ -1,6 +1,17 @@
 # ChangeLog for app-emulation/crossover-office-pro-bin
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.14 2007/12/02 23:39:34 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.15 2009/08/23 10:53:04 vapier Exp $
+
+*crossover-office-pro-bin-8.0.0 (23 Aug 2009)
+*crossover-office-pro-bin-7.1.0 (23 Aug 2009)
+*crossover-office-pro-bin-7.0.2 (23 Aug 2009)
+
+  23 Aug 2009; Mike Frysinger <vapier@gentoo.org>
+  +crossover-office-pro-bin-7.0.2.ebuild,
+  +crossover-office-pro-bin-7.1.0.ebuild,
+  +crossover-office-pro-bin-8.0.0.ebuild:
+  Version bump #231440 by Pacho Ramos, Robert A., Marcus D. Hanwell, and
+  Paul Hartman.
 
 *crossover-office-pro-bin-6.2.0 (02 Dec 2007)
 
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.0.2.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.0.2.ebuild
new file mode 100644
index 000000000000..66bf8bb270be
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.0.2.ebuild,v 1.1 2009/08/23 10:53:04 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="simplified/streamlined version of wine with commercial support"
+HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="nas"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+	x11-libs/libXrandr
+	x11-libs/libXi
+	x11-libs/libXmu
+	x11-libs/libXxf86dga
+	x11-libs/libXxf86vm
+	dev-util/desktop-file-utils
+	nas? ( media-libs/nas )
+	amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+	einfo "Please visit ${HOMEPAGE}"
+	einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+	unpack_makeself
+}
+
+src_install() {
+	dodir /opt/cxoffice
+	cp -r * "${D}"/opt/cxoffice || die "cp failed"
+	rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+	insinto /opt/cxoffice/etc
+	doins share/crossover/data/cxoffice.conf
+}
+
+pkg_postinst() {
+	elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+	elog "bottles and install Windows applications."
+}
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.1.0.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.1.0.ebuild
new file mode 100644
index 000000000000..71e7442268a2
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-7.1.0.ebuild,v 1.1 2009/08/23 10:53:04 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="simplified/streamlined version of wine with commercial support"
+HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="nas"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+	x11-libs/libXrandr
+	x11-libs/libXi
+	x11-libs/libXmu
+	x11-libs/libXxf86dga
+	x11-libs/libXxf86vm
+	dev-util/desktop-file-utils
+	nas? ( media-libs/nas )
+	amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+	einfo "Please visit ${HOMEPAGE}"
+	einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+	unpack_makeself
+}
+
+src_install() {
+	dodir /opt/cxoffice
+	cp -r * "${D}"/opt/cxoffice || die "cp failed"
+	rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+	insinto /opt/cxoffice/etc
+	doins share/crossover/data/cxoffice.conf
+}
+
+pkg_postinst() {
+	elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+	elog "bottles and install Windows applications."
+}
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-8.0.0.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-8.0.0.ebuild
new file mode 100644
index 000000000000..b04794a52179
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-8.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-8.0.0.ebuild,v 1.1 2009/08/23 10:53:04 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="simplified/streamlined version of wine with commercial support"
+HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="nas"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+	x11-libs/libXrandr
+	x11-libs/libXi
+	x11-libs/libXmu
+	x11-libs/libXxf86dga
+	x11-libs/libXxf86vm
+	dev-util/desktop-file-utils
+	nas? ( media-libs/nas )
+	amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+	einfo "Please visit ${HOMEPAGE}"
+	einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+	unpack_makeself
+}
+
+src_install() {
+	dodir /opt/cxoffice
+	cp -r * "${D}"/opt/cxoffice || die "cp failed"
+	rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+	insinto /opt/cxoffice/etc
+	doins share/crossover/data/cxoffice.conf
+}
+
+pkg_postinst() {
+	elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+	elog "bottles and install Windows applications."
+}
-- 
cgit v1.2.3-65-gdbad