From ef2ff2903d5298962a6efce870b1d6bcd153cb96 Mon Sep 17 00:00:00 2001
From: Samuli Suominen <ssuominen@gentoo.org>
Date: Sat, 29 Jan 2011 20:05:33 +0000
Subject: Fix building with x11-libs/libnotify >= 0.7.

(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
---
 app-cdr/gnomebaker/ChangeLog                       |  8 ++++++--
 .../files/gnomebaker-0.6.4-libnotify-0.7.patch     | 18 ++++++++++++++++
 app-cdr/gnomebaker/gnomebaker-0.6.4.ebuild         | 24 ++++++++++++++--------
 3 files changed, 39 insertions(+), 11 deletions(-)
 create mode 100644 app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch

(limited to 'app-cdr')

diff --git a/app-cdr/gnomebaker/ChangeLog b/app-cdr/gnomebaker/ChangeLog
index 9c34ab9893e0..110321083708 100644
--- a/app-cdr/gnomebaker/ChangeLog
+++ b/app-cdr/gnomebaker/ChangeLog
@@ -1,6 +1,10 @@
 # ChangeLog for app-cdr/gnomebaker
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/gnomebaker/ChangeLog,v 1.56 2008/09/28 09:23:28 loki_val Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gnomebaker/ChangeLog,v 1.57 2011/01/29 20:05:33 ssuominen Exp $
+
+  29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> gnomebaker-0.6.4.ebuild,
+  +files/gnomebaker-0.6.4-libnotify-0.7.patch:
+  Fix building with x11-libs/libnotify >= 0.7.
 
   28 Sep 2008; Peter Alfredsen <loki_val@gentoo.org>
   -files/gnomebaker-0.6.1-export-dynamic_for_glade.patch,
diff --git a/app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..27ae276d77a3
--- /dev/null
+++ b/app-cdr/gnomebaker/files/gnomebaker-0.6.4-libnotify-0.7.patch
@@ -0,0 +1,18 @@
+--- src/gblibnotify.c
++++ src/gblibnotify.c
+@@ -87,7 +87,15 @@
+ #ifdef HAVE_LIBNOTIFY
+ #if (LIBNOTIFY_VERSION_MINOR >= 3)
+ 	gint x, y;
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++	global_notify = notify_notification_new (subject, content, "");
++#else
+ 	global_notify = notify_notification_new (subject, content, "", NULL);
++#endif
++#else
++	global_notify = notify_notification_new (subject, content, "", NULL);
++#endif
+ 	/* not sure if we have to free the pixbuf since it could be used internally in libnotify */
+     GdkPixbuf *icon_pixbuf = gbcommon_get_icon_for_name("gnomebaker-48", 48);
+     /* I think they changed the api between 0.3.0 and 0.3.1+ */
diff --git a/app-cdr/gnomebaker/gnomebaker-0.6.4.ebuild b/app-cdr/gnomebaker/gnomebaker-0.6.4.ebuild
index 944d006bb1c2..6105bfa1c478 100644
--- a/app-cdr/gnomebaker/gnomebaker-0.6.4.ebuild
+++ b/app-cdr/gnomebaker/gnomebaker-0.6.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/gnomebaker/gnomebaker-0.6.4.ebuild,v 1.6 2008/08/30 14:40:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gnomebaker/gnomebaker-0.6.4.ebuild,v 1.7 2011/01/29 20:05:33 ssuominen Exp $
 
+EAPI=3
 GCONF_DEBUG=no
-
-inherit gnome2
+inherit eutils gnome2
 
 DESCRIPTION="GnomeBaker is a GTK2/Gnome cd burning application."
 HOMEPAGE="http://sourceforge.net/projects/gnomebaker"
@@ -33,14 +33,20 @@ RDEPEND=">=x11-libs/gtk+-2.8
 		>=media-libs/libogg-1.1.2
 		media-libs/gst-plugins-good )"
 DEPEND="${RDEPEND}
-	app-text/scrollkeeper
-	dev-util/pkgconfig
+	app-text/rarian
 	dev-util/intltool
-	sys-devel/gettext
-	dev-perl/XML-Parser"
+	dev-util/pkgconfig
+	sys-devel/gettext"
 
 pkg_setup() {
-	G2CONF="${G2CONF} --disable-dependency-tracking $(use_enable libnotify)"
+	G2CONF="${G2CONF}
+		--disable-dependency-tracking
+		$(use_enable libnotify)"
+}
+
+src_prepare() {
+	epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+	gnome2_src_prepare
 }
 
 src_install() {
-- 
cgit v1.2.3-65-gdbad