summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin')
-rw-r--r--xfce-extra/xfce4-weather-plugin/ChangeLog6
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild18
2 files changed, 16 insertions, 8 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/ChangeLog b/xfce-extra/xfce4-weather-plugin/ChangeLog
index 40ecbef26348..2f1c20bcb7a6 100644
--- a/xfce-extra/xfce4-weather-plugin/ChangeLog
+++ b/xfce-extra/xfce4-weather-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/xfce4-weather-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/ChangeLog,v 1.17 2012/02/10 12:28:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/ChangeLog,v 1.18 2012/04/09 21:22:32 ssuominen Exp $
+
+ 09 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-weather-plugin-0.7.4-r1.ebuild:
+ Use libdir instead of libexecdir.
10 Feb 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-weather-plugin-0.7.4-r1.ebuild:
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild
index 84944f7c50b5..c6cac7cef342 100644
--- a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild
@@ -1,30 +1,34 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild,v 1.3 2012/02/10 12:28:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.7.4-r1.ebuild,v 1.4 2012/04/09 21:22:32 ssuominen Exp $
EAPI=4
-inherit xfconf
+inherit multilib xfconf
DESCRIPTION="A weather plug-in for the Xfce desktop environment"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
-SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.7/${P}.tar.bz2"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug"
-RDEPEND=">=x11-libs/gtk+-2.6:2
+RDEPEND="dev-libs/libxml2
+ x11-libs/gtk+:2
>=xfce-base/libxfce4util-4.8
>=xfce-base/libxfcegui4-4.8
- >=xfce-base/xfce4-panel-4.8
- >=dev-libs/libxml2-2.4"
+ >=xfce-base/xfce4-panel-4.8"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
pkg_setup() {
- XFCONF=( $(xfconf_use_debug) )
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
DOCS=( AUTHORS ChangeLog NEWS README TODO )
}