summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/thunar-archive-plugin')
-rw-r--r--xfce-extra/thunar-archive-plugin/ChangeLog9
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch15
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch22
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild35
4 files changed, 80 insertions, 1 deletions
diff --git a/xfce-extra/thunar-archive-plugin/ChangeLog b/xfce-extra/thunar-archive-plugin/ChangeLog
index 30b66e92c217..10c016939c97 100644
--- a/xfce-extra/thunar-archive-plugin/ChangeLog
+++ b/xfce-extra/thunar-archive-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/thunar-archive-plugin
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/ChangeLog,v 1.33 2015/07/01 16:48:26 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/ChangeLog,v 1.34 2015/07/05 09:29:36 perfinion Exp $
+
+*thunar-archive-plugin-0.3.1-r2 (05 Jul 2015)
+
+ 05 Jul 2015; Jason Zaman <perfinion@gentoo.org>
+ +files/0.3.1-add-support-symlinks.patch, +files/0.3.1-fix-kde-ark.patch,
+ +thunar-archive-plugin-0.3.1-r2.ebuild:
+ fix kde ark support thanks to Alex Efros, bug 553722
01 Jul 2015; Mikle Kolyada <zlogene@gentoo.org>
thunar-archive-plugin-0.3.1-r1.ebuild:
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch
new file mode 100644
index 000000000000..bbe5f566a4c5
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch
@@ -0,0 +1,15 @@
+diff -ur thunar-archive-plugin-0.3.1.old/scripts/Makefile.am thunar-archive-plugin-0.3.1/scripts/Makefile.am
+--- thunar-archive-plugin-0.3.1.old/scripts/Makefile.am 2013-05-11 13:48:30.000000000 +0400
++++ thunar-archive-plugin-0.3.1/scripts/Makefile.am 2015-07-05 12:55:32.052090677 +0400
+@@ -9,8 +9,9 @@
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(wrapperdir)
+ -( cd $(DESTDIR)$(wrapperdir) ; \
+- test -f gnome-file-roller.tap \
+- || ln -sf file-roller.tap gnome-file-roller.tap )
++ ln -sf ark.tap kde4-ark.tap; \
++ ln -sf file-roller.tap gnome-file-roller.tap; \
++ ln -sf file-roller.tap org.gnome.FileRoller.tap; )
+
+ EXTRA_DIST = \
+ $(wrapper_SCRIPTS) \
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch
new file mode 100644
index 000000000000..e95fbbe0e407
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch
@@ -0,0 +1,22 @@
+diff -ur thunar-archive-plugin-0.3.1.old/scripts/ark.tap thunar-archive-plugin-0.3.1/scripts/ark.tap
+--- thunar-archive-plugin-0.3.1.old/scripts/ark.tap 2013-05-11 13:48:30.000000000 +0400
++++ thunar-archive-plugin-0.3.1/scripts/ark.tap 2015-07-05 12:56:25.288680104 +0400
+@@ -30,15 +30,15 @@
+ # check the action
+ case $action in
+ create)
+- exec ark --add "$@"
++ exec ark --dialog --add "$@"
+ ;;
+
+ extract-here)
+- exec ark --extract-to "$folder" "$@"
++ exec ark --batch --destination "$folder" "$@"
+ ;;
+
+ extract-to)
+- exec ark --extract "$@"
++ exec ark --batch --dialog --autodestination "$@"
+ ;;
+
+ *)
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..cb8d50ed5fe3
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild,v 1.1 2015/07/05 09:29:36 perfinion Exp $
+
+EAPI=5
+
+EAUTORECONF="yes"
+inherit xfconf
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/thunar-1.2:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/0.3.1-add-engrampa-support.patch
+ "${FILESDIR}"/0.3.1-fix-kde-ark.patch
+ "${FILESDIR}"/0.3.1-add-support-symlinks.patch
+ )
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}