summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmacpimon')
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild40
1 files changed, 17 insertions, 23 deletions
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
index 83d1c9805a28..c472e5606015 100644
--- a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.6 2007/07/22 05:29:57 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.7 2008/06/29 13:12:18 drac Exp $
inherit eutils
-IUSE=""
-
DESCRIPTION="WMaker DockApp that monitors the temperature and Speedstep features in new ACPI-based systems."
HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -13,6 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXext
@@ -21,34 +20,29 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
-src_unpack()
-{
+src_unpack() {
unpack ${A}
# patch wmacpimon.c file to set default path for
# wmacpimon.prc to /var/tmp/
- cd ${S}
- epatch ${FILESDIR}/wmacpimon.c.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/wmacpimon.c.patch
}
-src_compile()
-{
- make \
- CFLAGS="${CFLAGS} -DACPI -Wall -I/usr/X11R6/include" \
- LDFLAGS="${CFLAGS} -DACPI -L/usr/X11R6/lib -lX11 -lXpm -lXext" \
- || die "Compilation failed"
+src_compile() {
+ emake CFLAGS="${CFLAGS} -DACPI -Wall" \
+ LDFLAGS="${CFLAGS} -DACPI -lX11 -lXpm -lXext" \
+ || die "emake failed."
}
-src_install()
-{
- dobin wmacpimond wmacpimon
+src_install() {
+ dobin wmacpimond wmacpimon || die "dobin failed."
dodoc AUTHORS ChangeLog README
- newinitd ${FILESDIR}/wmacpimon.initscript wmacpimon
+ newinitd "${FILESDIR}"/wmacpimon.initscript wmacpimon
}
-pkg_postinst()
-{
- einfo "Remember to start the wmacpimond daemon"
- einfo "(by issuing the \"/etc/init.d/wmacpimon start\" command)"
- einfo "before you attempt to run wmacpimon..."
+pkg_postinst() {
+ elog "Remember to start the wmacpimond daemon"
+ elog "(by issuing the \"/etc/init.d/wmacpimon start\" command)"
+ elog "before you attempt to run wmacpimon..."
}