summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dmenu/ChangeLog7
-rw-r--r--x11-misc/dmenu/dmenu-1.9.ebuild80
-rw-r--r--x11-misc/dmenu/files/digest-dmenu-1.93
3 files changed, 89 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index 2bc4328c1693..60b5ef996276 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.3 2007/01/07 14:53:07 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.4 2007/01/13 14:10:36 cedk Exp $
+
+*dmenu-1.9 (13 Jan 2007)
+
+ 13 Jan 2007; Cedric Krier <cedk@gentoo.org> +dmenu-1.9.ebuild:
+ Version bump
07 Jan 2007; Cedric Krier <cedk@gentoo.org> dmenu-1.8-r1.ebuild:
Improve pkg_preinst
diff --git a/x11-misc/dmenu/dmenu-1.9.ebuild b/x11-misc/dmenu/dmenu-1.9.ebuild
new file mode 100644
index 000000000000..bea2548c5450
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-1.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-1.9.ebuild,v 1.1 2007/01/13 14:10:36 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://suckless.org/view/dynamic+window+manager"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="savedconfig"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ local conf root
+ for conf in ${PF} ${P} ${PN}; do
+ for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
+ configfile=${root}etc/portage/savedconfig/${conf}.config.h
+ if [[ -r ${configfile} ]]; then
+ elog "Found your ${configfile} and using it."
+ cp -f ${configfile} "${S}"/${PN}.h
+ return 0
+ fi
+ done
+ done
+ ewarn "Could not locate user configfile, so we will save a default one."
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins ${PN}.h ${PF}.config.h
+
+ dodoc README
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/
+ fi
+}
+
+pkg_postinst() {
+ if use savedconfig; then
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ elog "Saving this build config to ${config_dir}/${PF}.config.h"
+ einfo "Read this ebuild for more info on how to take advantage of this option."
+ mkdir -p "${config_dir}"
+ cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
+ fi
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+}
diff --git a/x11-misc/dmenu/files/digest-dmenu-1.9 b/x11-misc/dmenu/files/digest-dmenu-1.9
new file mode 100644
index 000000000000..4a333422dbdf
--- /dev/null
+++ b/x11-misc/dmenu/files/digest-dmenu-1.9
@@ -0,0 +1,3 @@
+MD5 cdb83ce9bc937490e66289b951127263 dmenu-1.9.tar.gz 7993
+RMD160 e8099be785a2e94161dea87c8ec91741c4ac9339 dmenu-1.9.tar.gz 7993
+SHA256 3126a58efa094660162a3af28a01b0a4b2c8f3aee7710fed8fcd5ba47527b121 dmenu-1.9.tar.gz 7993