summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/ChangeLog7
-rw-r--r--x11-misc/x11vnc/files/x11vnc-0.9.12-warnings.patch57
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.10.ebuild6
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.11.ebuild6
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.12.ebuild8
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.9.ebuild6
6 files changed, 82 insertions, 8 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index c77bb5e3d76f..f77987313db9 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.91 2010/09/11 16:13:17 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.92 2010/09/25 20:18:14 swegener Exp $
+
+ 25 Sep 2010; Sven Wegener <swegener@gentoo.org> x11vnc-0.9.9.ebuild,
+ x11vnc-0.9.10.ebuild, x11vnc-0.9.11.ebuild, x11vnc-0.9.12.ebuild,
+ +files/x11vnc-0.9.12-warnings.patch:
+ Fix warnings, bug #336878 by Alexandre Ferreira.
*x11vnc-0.9.12 (11 Sep 2010)
diff --git a/x11-misc/x11vnc/files/x11vnc-0.9.12-warnings.patch b/x11-misc/x11vnc/files/x11vnc-0.9.12-warnings.patch
new file mode 100644
index 000000000000..cc3ac32c97d0
--- /dev/null
+++ b/x11-misc/x11vnc/files/x11vnc-0.9.12-warnings.patch
@@ -0,0 +1,57 @@
+diff -ru a/x11vnc/libvncserver/tightvnc-filetransfer/filetransfermsg.c b/x11vnc/libvncserver/tightvnc-filetransfer/filetransfermsg.c
+--- a/x11vnc/libvncserver/tightvnc-filetransfer/filetransfermsg.c 2009-10-07 15:21:23.000000000 -0500
++++ b/x11vnc/libvncserver/tightvnc-filetransfer/filetransfermsg.c 2010-09-11 18:49:58.100074877 -0500
+@@ -393,7 +393,7 @@
+ CreateFileDownloadZeroSizeDataMsg(unsigned long mTime)
+ {
+ FileTransferMsg fileDownloadZeroSizeDataMsg;
+- int length = sz_rfbFileDownloadDataMsg + sizeof(int);
++ int length = sz_rfbFileDownloadDataMsg + sizeof(unsigned long);
+ rfbFileDownloadDataMsg *pFDD = NULL;
+ char *pFollow = NULL;
+
+diff -ru a/x11vnc/x11vnc/remote.c b/x11vnc/x11vnc/remote.c
+--- a/x11vnc/x11vnc/remote.c 2010-09-09 22:46:48.000000000 -0500
++++ b/x11vnc/x11vnc/remote.c 2010-09-11 18:18:37.948074878 -0500
+@@ -5825,7 +5825,7 @@
+ }
+ if (!strcmp(p, "vncdisplay")) {
+ snprintf(buf, bufn, "aro=%s:%s", p,
+- NONUL(vnc_desktop_name));
++ vnc_desktop_name);
+ goto qry;
+ }
+ if (!strcmp(p, "icon_mode")) {
+@@ -6027,7 +6027,7 @@
+ if (!strcmp(p, "h") || !strcmp(p, "help") ||
+ !strcmp(p, "V") || !strcmp(p, "version") ||
+ !strcmp(p, "lastmod")) {
+- snprintf(buf, bufn, "aro=%s:%s", p, NONUL(lastmod));
++ snprintf(buf, bufn, "aro=%s:%s", p, lastmod);
+ goto qry;
+ }
+ if (!strcmp(p, "bg")) {
+diff -ru a/x11vnc/x11vnc/sslhelper.c b/x11vnc/x11vnc/sslhelper.c
+--- a/x11vnc/x11vnc/sslhelper.c 2010-09-09 22:46:48.000000000 -0500
++++ b/x11vnc/x11vnc/sslhelper.c 2010-09-11 18:19:42.436074878 -0500
+@@ -4004,7 +4004,7 @@
+ strncpy(last_get, rcookie, 100);
+ if (db) fprintf(stderr, "last_get: '%s'\n", last_get);
+ }
+- if (rcookie && strstr(rcookie, "VncViewer.class")) {
++ if (strstr(rcookie, "VncViewer.class")) {
+ rfbLog("\n");
+ rfbLog("helper[%d]:\n", pid);
+ rfbLog("***********************************************************\n");
+diff -ru a/x11vnc/x11vnc/userinput.c b/x11vnc/x11vnc/userinput.c
+--- a/x11vnc/x11vnc/userinput.c 2010-09-09 22:46:48.000000000 -0500
++++ b/x11vnc/x11vnc/userinput.c 2010-09-11 18:20:29.692074878 -0500
+@@ -1305,7 +1305,7 @@
+ int font_size = 15;
+ int win_y, scr_y, loc_cut = 4*font_size, y_cut = 10*font_size;
+
+- if (!xrecord_set_by_keys || !xrecord_name_info) {
++ if (!xrecord_set_by_keys) {
+ return 0;
+ }
+ if (xrecord_name_info[0] == '\0') {
diff --git a/x11-misc/x11vnc/x11vnc-0.9.10.ebuild b/x11-misc/x11vnc/x11vnc-0.9.10.ebuild
index c1138a840d47..4116649f5c08 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.10.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.10.ebuild,v 1.3 2010/08/28 10:38:02 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.10.ebuild,v 1.4 2010/09/25 20:18:14 swegener Exp $
EAPI="2"
@@ -48,7 +48,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.9.11-rename-pointer.patch
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.11-rename-pointer.patch \
+ "${FILESDIR}"/${PN}-0.9.12-warnings.patch
}
src_configure() {
diff --git a/x11-misc/x11vnc/x11vnc-0.9.11.ebuild b/x11-misc/x11vnc/x11vnc-0.9.11.ebuild
index 6c00ece42b8b..e48bafd3f321 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.11.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.11.ebuild,v 1.2 2010/08/28 11:40:05 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.11.ebuild,v 1.3 2010/09/25 20:18:14 swegener Exp $
EAPI="2"
@@ -48,7 +48,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-rename-pointer.patch
+ epatch \
+ "${FILESDIR}"/${P}-rename-pointer.patch \
+ "${FILESDIR}"/${PN}-0.9.12-warnings.patch
}
src_configure() {
diff --git a/x11-misc/x11vnc/x11vnc-0.9.12.ebuild b/x11-misc/x11vnc/x11vnc-0.9.12.ebuild
index 916959d53767..4e3edec40b33 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.12.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.12.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.12.ebuild,v 1.1 2010/09/11 16:13:17 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.12.ebuild,v 1.2 2010/09/25 20:18:14 swegener Exp $
EAPI="2"
+inherit eutils
+
DESCRIPTION="A VNC server for real X displays"
HOMEPAGE="http://www.karlrunge.com/x11vnc/"
SRC_URI="mirror://sourceforge/libvncserver/${P}.tar.gz"
@@ -45,6 +47,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch
+}
+
src_configure() {
econf \
$(use_with system-libvncserver) \
diff --git a/x11-misc/x11vnc/x11vnc-0.9.9.ebuild b/x11-misc/x11vnc/x11vnc-0.9.9.ebuild
index f839504705ad..2e26c78ad817 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.9.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.9.ebuild,v 1.11 2010/08/28 10:38:02 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.9.ebuild,v 1.12 2010/09/25 20:18:14 swegener Exp $
EAPI="2"
@@ -48,7 +48,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.9.11-rename-pointer.patch
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.11-rename-pointer.patch \
+ "${FILESDIR}"/${PN}-0.9.12-warnings.patch
}
src_configure() {