summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/fraqtive')
-rw-r--r--x11-misc/fraqtive/ChangeLog6
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.6.ebuild8
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.7.ebuild6
3 files changed, 12 insertions, 8 deletions
diff --git a/x11-misc/fraqtive/ChangeLog b/x11-misc/fraqtive/ChangeLog
index 6aa94fa4f6d0..bfda649b7cd1 100644
--- a/x11-misc/fraqtive/ChangeLog
+++ b/x11-misc/fraqtive/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fraqtive
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/ChangeLog,v 1.15 2015/01/22 10:50:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/ChangeLog,v 1.16 2015/01/28 22:22:41 mgorny Exp $
+
+ 28 Jan 2015; Michał Górny <mgorny@gentoo.org> fraqtive-0.4.6.ebuild,
+ fraqtive-0.4.7.ebuild:
+ Switch to CPU_FLAGS_X86.
*fraqtive-0.4.7 (22 Jan 2015)
diff --git a/x11-misc/fraqtive/fraqtive-0.4.6.ebuild b/x11-misc/fraqtive/fraqtive-0.4.6.ebuild
index 08029716b8dc..7d920f8bc96f 100644
--- a/x11-misc/fraqtive/fraqtive-0.4.6.ebuild
+++ b/x11-misc/fraqtive/fraqtive-0.4.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.6.ebuild,v 1.3 2014/07/01 23:53:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.6.ebuild,v 1.4 2015/01/28 22:22:41 mgorny Exp $
EAPI=5
inherit eutils gnome2-utils qt4-r2
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="sse2"
+IUSE="cpu_flags_x86_sse2"
DEPEND="
dev-qt/qtcore:4
@@ -25,7 +25,7 @@ RDEPEND="${DEPEND}"
src_configure() {
local conf="release"
- if use sse2; then
+ if use cpu_flags_x86_sse2; then
conf="$conf sse2"
else
conf="$conf no-sse2"
diff --git a/x11-misc/fraqtive/fraqtive-0.4.7.ebuild b/x11-misc/fraqtive/fraqtive-0.4.7.ebuild
index e228430c6f34..0d9ecb5b7283 100644
--- a/x11-misc/fraqtive/fraqtive-0.4.7.ebuild
+++ b/x11-misc/fraqtive/fraqtive-0.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.7.ebuild,v 1.1 2015/01/22 10:50:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.7.ebuild,v 1.2 2015/01/28 22:22:41 mgorny Exp $
EAPI=5
inherit eutils gnome2-utils qmake-utils toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="qt5 sse2"
+IUSE="qt5 cpu_flags_x86_sse2"
RDEPEND="
!qt5? (
@@ -37,7 +37,7 @@ src_configure() {
sed -i -e "s|-lGLU|$( ${PKG_CONFIG} --libs glu )|g" src/src.pro || die
local conf="release"
- if use sse2; then
+ if use cpu_flags_x86_sse2; then
conf="$conf sse2"
else
conf="$conf no-sse2"