summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/qt-webkit/qt-webkit-4.5.3-r2.ebuild')
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.5.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/qt-webkit/qt-webkit-4.5.3-r2.ebuild b/x11-libs/qt-webkit/qt-webkit-4.5.3-r2.ebuild
new file mode 100644
index 000000000000..d89daf1dcc67
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.5.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.3-r2.ebuild,v 1.1 2010/02/17 21:20:00 wired Exp $
+
+EAPI="2"
+inherit eutils qt4-build flag-o-matic
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-dbus-${PV}[debug=]
+ ~x11-libs/qt-gui-${PV}[dbus,debug=]
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[dbus,debug=]
+ media-sound/phonon ) )
+ kde? ( media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
+QT4_EXTRACT_DIRECTORIES="
+include/
+src/
+tools/"
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ epatch "${FILESDIR}"/30_webkit_unaligned_access.diff #235685
+ epatch "${FILESDIR}"/"${P}"-no-javascript-crash.patch #295573
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ # This fixes relocation overflows on alpha
+ use alpha && append-ldflags "-Wl,--no-relax"
+ myconf="${myconf} -webkit"
+ qt4-build_src_configure
+}