summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog7
-rw-r--r--x11-apps/xdm/files/0001-Fix-missing-linking-dependency-on-ldl.patch38
-rw-r--r--x11-apps/xdm/files/xdm.service7
-rw-r--r--x11-apps/xdm/xdm-1.1.10-r2.ebuild19
4 files changed, 64 insertions, 7 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 532d34e41ed4..8f3d34fb0999 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.118 2011/06/19 16:07:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.119 2011/08/28 07:46:04 mgorny Exp $
+
+ 28 Aug 2011; Michał Górny <mgorny@gentoo.org> xdm-1.1.10-r2.ebuild,
+ +files/0001-Fix-missing-linking-dependency-on-ldl.patch, files/xdm.service:
+ Rename systemd unit file from xdm@ to xdm as it isn't bound to a specific vt.
+ Fix underlinking (bug #369531).
19 Jun 2011; Michał Górny <mgorny@gentoo.org> xdm-1.1.10-r2.ebuild,
+files/xdm.service, -files/systemd-service.patch:
diff --git a/x11-apps/xdm/files/0001-Fix-missing-linking-dependency-on-ldl.patch b/x11-apps/xdm/files/0001-Fix-missing-linking-dependency-on-ldl.patch
new file mode 100644
index 000000000000..c42b67ade5c7
--- /dev/null
+++ b/x11-apps/xdm/files/0001-Fix-missing-linking-dependency-on-ldl.patch
@@ -0,0 +1,38 @@
+From 4014cde16310467e8b826da77f4ca5b0ae3d357f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fernando=20Tarl=C3=A1=20Cardoso=20Lemos?=
+ <fernandotcl@gmail.com>
+Date: Sat, 19 Feb 2011 17:53:08 -0200
+Subject: [PATCH] Fix missing linking dependency on -ldl.
+
+Recent versions of GCC ship with a linker that doesn't add the deps
+of the DSOs to the linking process. This behavior is also found in
+GNU gold. This change fixes building with those linkers.
+
+Some references:
+
+http://wiki.debian.org/ToolChain/DSOLinking
+https://fedoraproject.org/wiki/UnderstandingDSOLinkChange
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Reviewed-by: Gaetan Nadon <memsize@videotron.ca>
+---
+ configure.ac | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5d0f243..d9aa26a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -455,6 +455,9 @@ AM_CONDITIONAL(HAS_XDM_AUTH, test x$xdmauth = xyes -a x$xdmauth_enable != xno)
+
+ AC_SEARCH_LIBS(crypt, crypt)
+
++# Function dl() comes from the C library or -ldl
++AC_SEARCH_LIBS([dlopen], [dl])
++
+ AC_SUBST(XDM_CFLAGS)
+ AC_SUBST(XDM_LIBS)
+ AC_SUBST(XDM_LDFLAGS)
+--
+1.7.6.1
+
diff --git a/x11-apps/xdm/files/xdm.service b/x11-apps/xdm/files/xdm.service
index faaf72444498..3e4b840a757b 100644
--- a/x11-apps/xdm/files/xdm.service
+++ b/x11-apps/xdm/files/xdm.service
@@ -1,10 +1,9 @@
[Unit]
-Description=X-Window Display Manager on %I
-Requires=dev-%i.device
-After=dev-%i.device systemd-user-sessions.service
+Description=X-Window Display Manager
+After=systemd-user-sessions.service
[Service]
ExecStart=/usr/bin/xdm -nodaemon
[Install]
-Alias=graphical.target.wants/xdm@tty7.service
+Alias=graphical.target.wants/xdm.service
diff --git a/x11-apps/xdm/xdm-1.1.10-r2.ebuild b/x11-apps/xdm/xdm-1.1.10-r2.ebuild
index 2b6da9df148a..cc6da01e1766 100644
--- a/x11-apps/xdm/xdm-1.1.10-r2.ebuild
+++ b/x11-apps/xdm/xdm-1.1.10-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.10-r2.ebuild,v 1.2 2011/06/19 16:07:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.10-r2.ebuild,v 1.3 2011/08/28 07:46:04 mgorny Exp $
EAPI=3
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/xwilling-hang.patch
+ # bug #369531 (underlinking)
+ "${FILESDIR}"/0001-Fix-missing-linking-dependency-on-ldl.patch
)
pkg_setup() {
@@ -53,5 +55,18 @@ src_install() {
# Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
keepdir /var/lib/xdm
- systemd_newunit "${FILESDIR}"/xdm.service 'xdm@.service' || die
+ systemd_dounit "${FILESDIR}"/xdm.service || die
+}
+
+pkg_postinst() {
+ # Mea culpa, feel free to remove that after some time --mgorny.
+ if [[ -L "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}'@tty7'.service ]]
+ then
+ ebegin "Renaming ${PN}@tty7.service to ${PN}.service"
+ ln -s "${ROOT}"/lib/systemd/system/xdm.service \
+ "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}.service && \
+ rm -f "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}'@tty7'.service
+ eend ${?} \
+ "Please try to re-enable xdm.service"
+ fi
}