summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/uzbl/uzbl-9999.ebuild')
-rw-r--r--www-client/uzbl/uzbl-9999.ebuild54
1 files changed, 35 insertions, 19 deletions
diff --git a/www-client/uzbl/uzbl-9999.ebuild b/www-client/uzbl/uzbl-9999.ebuild
index 4834ded6c460..802590196a72 100644
--- a/www-client/uzbl/uzbl-9999.ebuild
+++ b/www-client/uzbl/uzbl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-9999.ebuild,v 1.5 2009/12/05 17:37:22 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-9999.ebuild,v 1.6 2009/12/08 12:36:47 wired Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI=""
EGIT_REPO_URI="git://github.com/Dieterbe/uzbl.git"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+LICENSE="LGPL-2.1 MPL-1.1"
SLOT="0"
KEYWORDS=""
IUSE="+browser experimental helpers +tabbed"
@@ -31,6 +31,9 @@ DEPEND="
RDEPEND="
${COMMON_DEPEND}
+ browser? (
+ x11-misc/xclip
+ )
helpers? (
dev-lang/perl
dev-python/pygtk
@@ -46,17 +49,32 @@ RDEPEND="
pkg_setup() {
use experimental && EGIT_BRANCH="experimental"
- ewarn "Since the helpers are growing into a fine list I've decided"
- ewarn "to keep them under a single USE flag to avoid a USE hell".
- ewarn "You can always install the ones you need manually if you don't"
- ewarn "need them all."
- ewarn
+ if ! use helpers; then
+ elog "uzbl's extra scripts use various optional applications:"
+ elog
+ elog " dev-lang/perl"
+ elog " dev-python/pygtk"
+ elog " dev-python/pygobject"
+ elog " gnome-extra/zenity"
+ elog " net-misc/socat"
+ elog " x11-libs/pango"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/xclip"
+ elog
+ elog "Make sure you emerge the ones you need manually."
+ elog "You may also activate the *helpers* USE flag to"
+ elog "install all of them automatically."
+ else
+ einfo "You have enabled the *helpers* USE flag that installs"
+ einfo "various optional applications used by uzbl's extra scripts."
+ fi
if use tabbed && ! use browser; then
- ewarn "You enabled 'tabbed' but not 'browser' which is required by"
- ewarn "'tabbed'. uzbl-browser will be installed anyway to fulfill the"
- ewarn "dependency."
ewarn
+ ewarn "You enabled the *tabbed* USE flag but not *browser*."
+ ewarn "*tabbed* depends on *browser*, so it will be disabled."
+ ewarn
+ ebeep 3
fi
}
@@ -77,14 +95,12 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-core || die "Installation failed"
- if use browser || use tabbed; then
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-browser || die "Installation failed"
- fi
- if use tabbed; then
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-tabbed || die "Installation failed"
- fi
+ local targets="install-uzbl-core"
+ use browser && targets="${targets} install-uzbl-browser"
+ use browser && use tabbed && targets="${targets} install-uzbl-tabbed"
+
+ emake DESTDIR="${D}" PREFIX="/usr" ${targets} || die "Installation failed"
- # Move the docs to /usr/share/doc instead.
- dodoc AUTHORS README docs/*
+ # Install the docs in /usr/share/doc.
+ dodoc AUTHORS README docs/* || die "docs install failed"
}