summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/ChangeLog10
-rw-r--r--www-apps/dokuwiki/dokuwiki-20091225b.ebuild71
2 files changed, 79 insertions, 2 deletions
diff --git a/www-apps/dokuwiki/ChangeLog b/www-apps/dokuwiki/ChangeLog
index 3dc92555e7de..cf6b108f3740 100644
--- a/www-apps/dokuwiki/ChangeLog
+++ b/www-apps/dokuwiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/dokuwiki
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.41 2009/07/19 18:42:18 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.42 2010/01/15 20:14:48 ramereth Exp $
+
+*dokuwiki-20091225b (15 Jan 2010)
+
+ 15 Jan 2010; Lance Albertson <ramereth@gentoo.org>
+ +dokuwiki-20091225b.ebuild:
+ Version bump, fixes #299360
19 Jul 2009; nixnut <nixnut@gentoo.org> dokuwiki-20090214b.ebuild:
ppc stable #272431
diff --git a/www-apps/dokuwiki/dokuwiki-20091225b.ebuild b/www-apps/dokuwiki/dokuwiki-20091225b.ebuild
new file mode 100644
index 000000000000..bbb6327bd8c5
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20091225b.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20091225b.ebuild,v 1.1 2010/01/15 20:14:48 ramereth Exp $
+
+inherit webapp depend.php
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://www.splitbrain.org/_media/projects/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${PN}-${MY_BASE_PV}"
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use cli expat
+ else
+ require_php_with_use cli xml
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # create initial changes file
+ touch data/changes.log
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+ rm -f README COPYING VERSION
+
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}