summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/digest-glibc-2.66
-rw-r--r--sys-libs/glibc/glibc-2.6.ebuild15
2 files changed, 16 insertions, 5 deletions
diff --git a/sys-libs/glibc/files/digest-glibc-2.6 b/sys-libs/glibc/files/digest-glibc-2.6
index 073fe790647c..6b45f3174955 100644
--- a/sys-libs/glibc/files/digest-glibc-2.6
+++ b/sys-libs/glibc/files/digest-glibc-2.6
@@ -1,6 +1,6 @@
-MD5 58f9c91a22877a8aa7b329f2048a63e4 glibc-2.6-patches-1.4.tar.bz2 88209
-RMD160 b0bd771cebbac93d812bf352c02346d84b05c4c1 glibc-2.6-patches-1.4.tar.bz2 88209
-SHA256 8a20749c5fe874d17174ea4743c74bf5479efeac79f44418814c398713cd4f7d glibc-2.6-patches-1.4.tar.bz2 88209
+MD5 19e5eac422209d6399103ce9d75fdf3b glibc-2.6-patches-1.5.tar.bz2 90012
+RMD160 f55f2fdb00f481504f47b2cb27726bd7ed989527 glibc-2.6-patches-1.5.tar.bz2 90012
+SHA256 76ba64cbfe9698a870c052b26b91102c7635bd70401bbe1042e81bba78f22c8c glibc-2.6-patches-1.5.tar.bz2 90012
MD5 0f471d7cb29dd07786082ad23f787949 glibc-2.6.tar.bz2 15637436
RMD160 9f201f54d41941df299ab88722f4095dd417a5e4 glibc-2.6.tar.bz2 15637436
SHA256 f773ae5762c193091df46244ce355e38d358e8f8be088be0dbf934a193063bba glibc-2.6.tar.bz2 15637436
diff --git a/sys-libs/glibc/glibc-2.6.ebuild b/sys-libs/glibc/glibc-2.6.ebuild
index 47a28aa96982..9ab416a3a380 100644
--- a/sys-libs/glibc/glibc-2.6.ebuild
+++ b/sys-libs/glibc/glibc-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.ebuild,v 1.13 2007/07/24 08:10:35 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.ebuild,v 1.14 2007/07/25 04:11:49 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -27,7 +27,7 @@ GLIBC_MANPAGE_VERSION="none"
GLIBC_INFOPAGE_VERSION="none"
# Gentoo patchset
-PATCH_VER="1.4"
+PATCH_VER="1.5"
GENTOO_TOOLCHAIN_BASE_URI="mirror://gentoo"
GENTOO_TOOLCHAIN_DEV_URI="http://dev.gentoo.org/~azarah/glibc/XXX http://dev.gentoo.org/~vapier/dist/XXX"
@@ -948,6 +948,10 @@ glibc_do_configure() {
cd "${GBUILDDIR}"
einfo "Configuring GLIBC for $1 with: ${myconf// /\n\t\t}"
"${S}"/configure ${myconf} || die "failed to configure glibc"
+
+ # since we'll be punting them for cross-compilers, and they can cause
+ # problems (ia64+static), we'll just skip building altogether
+ is_crosscompile && sed -i '1ibuild-programs = no' config.make
}
fix_lib64_symlinks() {
@@ -1084,6 +1088,13 @@ pkg_setup() {
fi
fi
+ # users have had a chance to phase themselves, time to give em the boot
+ if [[ -e ${ROOT}/etc/locale.gen ]] && [[ -e ${ROOT}/etc/locales.build ]] ; then
+ eerror "You still haven't deleted ${ROOT}/etc/locales.build."
+ eerror "Do so now after making sure ${ROOT}/etc/locale.gen is kosher."
+ die "lazy upgrader detected"
+ fi
+
if [[ ${CTARGET} == i386-* ]] ; then
eerror "i386 CHOSTs are no longer supported."
eerror "Chances are you don't actually want/need i386."